aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ppc40x/image/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-07-24 20:01:54 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-07-24 20:01:54 +0000
commit49259b3eb3363fd8f6f533d93064512bdccb0b36 (patch)
tree4fda5bef32503d05f4daccf1d6ad60ff565dc8da /target/linux/ppc40x/image/Makefile
parent1613beb6165b267cfd7ebf0fac594f7ebe00dca6 (diff)
downloadmaster-187ad058-49259b3eb3363fd8f6f533d93064512bdccb0b36.tar.gz
master-187ad058-49259b3eb3363fd8f6f533d93064512bdccb0b36.tar.bz2
master-187ad058-49259b3eb3363fd8f6f533d93064512bdccb0b36.zip
[ppc40x] add support for the OpenRB Medium board
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16970 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ppc40x/image/Makefile')
-rw-r--r--target/linux/ppc40x/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ppc40x/image/Makefile b/target/linux/ppc40x/image/Makefile
index 60d85bffdd..d9586dd153 100644
--- a/target/linux/ppc40x/image/Makefile
+++ b/target/linux/ppc40x/image/Makefile
@@ -43,6 +43,10 @@ define Image/Build/jffs2-64k
dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb-light bs=1152k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-openrb-light-jffs2.img
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb-medium bs=1152k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-openrb-medium-jffs2.img
endef
define Image/Build/squashfs
@@ -64,6 +68,10 @@ define Image/Build/squashfs
dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb-light bs=1152k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-openrb-light-$(1).img
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb-medium bs=1152k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-openrb-medium-$(1).img
endef
$(eval $(call BuildImage))