aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/package/wlcompat
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-06-30 21:36:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-06-30 21:36:59 +0000
commitf04b69b7a3563c19b79be24cd81b792f9a1d1a21 (patch)
tree6c9dab07dd0ec541d4688aee0ddfa7248fee954a /target/linux/package/wlcompat
parentcf74fdd9b88e90f111ac884141c7addd39c267c5 (diff)
downloadmaster-187ad058-f04b69b7a3563c19b79be24cd81b792f9a1d1a21.tar.gz
master-187ad058-f04b69b7a3563c19b79be24cd81b792f9a1d1a21.tar.bz2
master-187ad058-f04b69b7a3563c19b79be24cd81b792f9a1d1a21.zip
split wlcompat package in HEAD, too
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1298 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/package/wlcompat')
-rw-r--r--target/linux/package/wlcompat/Config.in8
-rw-r--r--target/linux/package/wlcompat/Makefile10
2 files changed, 16 insertions, 2 deletions
diff --git a/target/linux/package/wlcompat/Config.in b/target/linux/package/wlcompat/Config.in
index 926cf4b3c4..5958eeb899 100644
--- a/target/linux/package/wlcompat/Config.in
+++ b/target/linux/package/wlcompat/Config.in
@@ -5,3 +5,11 @@ config BR2_PACKAGE_KMOD_WLCOMPAT
help
A wrapper module, that provides Wireless Extension support for the
proprietary Broadcom wl module.
+
+config BR2_PACKAGE_KMOD_WLCOMPAT_DEBUG
+ tristate "kmod-wlcompat-debug"
+ default m
+ depends BR2_PACKAGE_KMOD_BRCM_WL
+ help
+ A wrapper module, that provides Wireless Extension support for the
+ proprietary Broadcom wl module. (debug version)
diff --git a/target/linux/package/wlcompat/Makefile b/target/linux/package/wlcompat/Makefile
index 706948e8ea..419b4d2f5e 100644
--- a/target/linux/package/wlcompat/Makefile
+++ b/target/linux/package/wlcompat/Makefile
@@ -32,9 +32,15 @@ $(PKG_BUILD_DIR)/wlcompat.o: $(PKG_BUILD_DIR)/.prepared
$(PKG_BUILD_DIR)/wlcompat-debug.o: $(PKG_BUILD_DIR)/.prepared
$(TARGET_CC) -DDEBUG $(WLCOMPAT_FLAGS) -o $@ wlcompat.c
-$(IPKG_KMOD_WLCOMPAT): $(PKG_BUILD_DIR)/wlcompat.o $(PKG_BUILD_DIR)/wlcompat-debug.o
+$(IPKG_KMOD_WLCOMPAT): $(PKG_BUILD_DIR)/wlcompat.o
mkdir -p $(IDIR_KMOD_WLCOMPAT)/etc/modules.d
echo "wlcompat" > $(IDIR_KMOD_WLCOMPAT)/etc/modules.d/10-wlcompat
mkdir -p $(IDIR_KMOD_WLCOMPAT)/lib/modules/$(LINUX_VERSION)
- cp $(PKG_BUILD_DIR)/*.o $(IDIR_KMOD_WLCOMPAT)/lib/modules/$(LINUX_VERSION)/
+ cp $(PKG_BUILD_DIR)/wlcompat.o $(IDIR_KMOD_WLCOMPAT)/lib/modules/$(LINUX_VERSION)/
$(IPKG_BUILD) $(IDIR_KMOD_WLCOMPAT) $(PACKAGE_DIR)
+
+$(IPKG_KMOD_WLCOMPAT_DEBUG): $(PKG_BUILD_DIR)/wlcompat-debug.o
+ mkdir -p $(IDIR_KMOD_WLCOMPAT)/lib/modules/$(LINUX_VERSION)
+ cp $(PKG_BUILD_DIR)/wlcompat-debug.o $(IDIR_KMOD_WLCOMPAT)/lib/modules/$(LINUX_VERSION)/
+ $(IPKG_BUILD) $(IDIR_KMOD_WLCOMPAT_DEBUG) $(PACKAGE_DIR)
+