aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.1/700-oxnas-dwmac.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-19 10:09:36 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-19 10:09:36 +0000
commit588215df4d8e2f89c6061fb8cfa16442faba9694 (patch)
tree7fc7b0b4b31155d5edfa3f22a7781654e86cfefc /target/linux/oxnas/patches-4.1/700-oxnas-dwmac.patch
parente84f12fbbc584a37121e41e2d529663e1e2ca43f (diff)
downloadmaster-187ad058-588215df4d8e2f89c6061fb8cfa16442faba9694.tar.gz
master-187ad058-588215df4d8e2f89c6061fb8cfa16442faba9694.tar.bz2
master-187ad058-588215df4d8e2f89c6061fb8cfa16442faba9694.zip
oxnas: move gmac soc glue from mach to stmmac driver
Still a lot of kernel-version ifdef'ery, but imho that's easy to remove once obsoleted and avoids duplicate code in the meantime. Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47218 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/oxnas/patches-4.1/700-oxnas-dwmac.patch')
-rw-r--r--target/linux/oxnas/patches-4.1/700-oxnas-dwmac.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.1/700-oxnas-dwmac.patch b/target/linux/oxnas/patches-4.1/700-oxnas-dwmac.patch
new file mode 100644
index 0000000000..dde3140a1f
--- /dev/null
+++ b/target/linux/oxnas/patches-4.1/700-oxnas-dwmac.patch
@@ -0,0 +1,25 @@
+--- a/drivers/net/ethernet/stmicro/stmmac/Kconfig
++++ b/drivers/net/ethernet/stmicro/stmmac/Kconfig
+@@ -20,7 +20,7 @@ config STMMAC_PLATFORM
+ ---help---
+ This selects the platform specific bus support for the stmmac driver.
+ This is the driver used on several SoCs:
+- STi, Allwinner, Amlogic Meson, Altera SOCFPGA.
++ STi, Allwinner, Amlogic Meson, Altera SOCFPGA and Oxnas.
+
+ If you have a controller with this interface, say Y or M here.
+
+--- a/drivers/net/ethernet/stmicro/stmmac/Makefile
++++ b/drivers/net/ethernet/stmicro/stmmac/Makefile
+@@ -5,8 +5,9 @@ stmmac-objs:= stmmac_main.o stmmac_ethto
+ mmc_core.o stmmac_hwtstamp.o stmmac_ptp.o $(stmmac-y)
+
+ obj-$(CONFIG_STMMAC_PLATFORM) += stmmac-platform.o
+-stmmac-platform-objs:= stmmac_platform.o dwmac-meson.o dwmac-sunxi.o \
+- dwmac-sti.o dwmac-socfpga.o dwmac-rk.o
++stmmac-platform-objs:= stmmac_platform.o dwmac-meson.o dwmac-oxnas.o \
++ dwmac-sunxi.o dwmac-sti.o dwmac-socfpga.o \
++ dwmac-rk.o
+
+ obj-$(CONFIG_STMMAC_PCI) += stmmac-pci.o
+ stmmac-pci-objs:= stmmac_pci.o