aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.1/500-oxnas-sata.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-08-17 06:03:57 +0000
committerJohn Crispin <blogic@openwrt.org>2015-08-17 06:03:57 +0000
commit46d4c7a7d0d49edaf79b8f92e9c1b54405e56157 (patch)
tree54c265fd011c147f0febcb7c86c0163df9747ec2 /target/linux/oxnas/patches-4.1/500-oxnas-sata.patch
parentd3ea787445646907237906a5c33c49fed6a95a68 (diff)
downloadmaster-187ad058-46d4c7a7d0d49edaf79b8f92e9c1b54405e56157.tar.gz
master-187ad058-46d4c7a7d0d49edaf79b8f92e9c1b54405e56157.tar.bz2
master-187ad058-46d4c7a7d0d49edaf79b8f92e9c1b54405e56157.zip
oxnas: prepare for kernel 4.1
Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46636 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/oxnas/patches-4.1/500-oxnas-sata.patch')
-rw-r--r--target/linux/oxnas/patches-4.1/500-oxnas-sata.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.1/500-oxnas-sata.patch b/target/linux/oxnas/patches-4.1/500-oxnas-sata.patch
new file mode 100644
index 0000000000..8c59b219fd
--- /dev/null
+++ b/target/linux/oxnas/patches-4.1/500-oxnas-sata.patch
@@ -0,0 +1,26 @@
+--- a/drivers/ata/Kconfig
++++ b/drivers/ata/Kconfig
+@@ -402,6 +402,13 @@ config SATA_VITESSE
+
+ If unsure, say N.
+
++config SATA_OXNAS
++ tristate "PLXTECH NAS782X SATA support"
++ help
++ This option enables support for Nas782x Serial ATA controller.
++
++ If unsure, say N.
++
+ comment "PATA SFF controllers with BMDMA"
+
+ config PATA_ALI
+--- a/drivers/ata/Makefile
++++ b/drivers/ata/Makefile
+@@ -37,6 +37,7 @@ obj-$(CONFIG_SATA_SVW) += sata_svw.o
+ obj-$(CONFIG_SATA_ULI) += sata_uli.o
+ obj-$(CONFIG_SATA_VIA) += sata_via.o
+ obj-$(CONFIG_SATA_VITESSE) += sata_vsc.o
++obj-$(CONFIG_SATA_OXNAS) += sata_oxnas.o
+
+ # SFF PATA w/ BMDMA
+ obj-$(CONFIG_PATA_ALI) += pata_ali.o