aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.0/300-introduce-oxnas-platform.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-06-19 11:12:43 +0000
committerJonas Gorski <jogo@openwrt.org>2015-06-19 11:12:43 +0000
commit03110a1254dc8ec2564cacb1e8e236412b7822bd (patch)
tree6917622e0e5f695fd1ef9ea5cd3f811047f9ea27 /target/linux/oxnas/patches-4.0/300-introduce-oxnas-platform.patch
parent657b75acce863c2efbd0ba334473b4c575999448 (diff)
downloadmaster-187ad058-03110a1254dc8ec2564cacb1e8e236412b7822bd.tar.gz
master-187ad058-03110a1254dc8ec2564cacb1e8e236412b7822bd.tar.bz2
master-187ad058-03110a1254dc8ec2564cacb1e8e236412b7822bd.zip
kernel: update 4.0 to 4.0.5
Changelog: * https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.0.5 Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46063 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/oxnas/patches-4.0/300-introduce-oxnas-platform.patch')
-rw-r--r--target/linux/oxnas/patches-4.0/300-introduce-oxnas-platform.patch32
1 files changed, 11 insertions, 21 deletions
diff --git a/target/linux/oxnas/patches-4.0/300-introduce-oxnas-platform.patch b/target/linux/oxnas/patches-4.0/300-introduce-oxnas-platform.patch
index 465e5b7c47..078eddc1ec 100644
--- a/target/linux/oxnas/patches-4.0/300-introduce-oxnas-platform.patch
+++ b/target/linux/oxnas/patches-4.0/300-introduce-oxnas-platform.patch
@@ -1,7 +1,5 @@
-Index: linux-4.0-rc4/arch/arm/Kconfig
-===================================================================
---- linux-4.0-rc4.orig/arch/arm/Kconfig
-+++ linux-4.0-rc4/arch/arm/Kconfig
+--- a/arch/arm/Kconfig
++++ b/arch/arm/Kconfig
@@ -356,6 +356,17 @@ config ARCH_VERSATILE
help
This enables support for ARM Ltd Versatile board.
@@ -20,7 +18,7 @@ Index: linux-4.0-rc4/arch/arm/Kconfig
config ARCH_AT91
bool "Atmel AT91"
select ARCH_REQUIRE_GPIOLIB
-@@ -916,6 +927,8 @@ source "arch/arm/mach-omap2/Kconfig"
+@@ -917,6 +928,8 @@ source "arch/arm/mach-omap2/Kconfig"
source "arch/arm/mach-orion5x/Kconfig"
@@ -29,10 +27,8 @@ Index: linux-4.0-rc4/arch/arm/Kconfig
source "arch/arm/mach-picoxcell/Kconfig"
source "arch/arm/mach-pxa/Kconfig"
-Index: linux-4.0-rc4/arch/arm/Makefile
-===================================================================
---- linux-4.0-rc4.orig/arch/arm/Makefile
-+++ linux-4.0-rc4/arch/arm/Makefile
+--- a/arch/arm/Makefile
++++ b/arch/arm/Makefile
@@ -188,6 +188,7 @@ machine-$(CONFIG_ARCH_NSPIRE) += nspire
machine-$(CONFIG_ARCH_OMAP1) += omap1
machine-$(CONFIG_ARCH_OMAP2PLUS) += omap2
@@ -41,10 +37,8 @@ Index: linux-4.0-rc4/arch/arm/Makefile
machine-$(CONFIG_ARCH_PICOXCELL) += picoxcell
machine-$(CONFIG_ARCH_PXA) += pxa
machine-$(CONFIG_ARCH_QCOM) += qcom
-Index: linux-4.0-rc4/arch/arm/boot/dts/Makefile
-===================================================================
---- linux-4.0-rc4.orig/arch/arm/boot/dts/Makefile
-+++ linux-4.0-rc4/arch/arm/boot/dts/Makefile
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
@@ -429,6 +429,7 @@ dtb-$(CONFIG_ARCH_ORION5X) += \
orion5x-lacie-ethernet-disk-mini-v2.dtb \
orion5x-maxtor-shared-storage-2.dtb \
@@ -53,10 +47,8 @@ Index: linux-4.0-rc4/arch/arm/boot/dts/Makefile
dtb-$(CONFIG_ARCH_PRIMA2) += \
prima2-evb.dtb
dtb-$(CONFIG_ARCH_QCOM) += \
-Index: linux-4.0-rc4/arch/arm/tools/mach-types
-===================================================================
---- linux-4.0-rc4.orig/arch/arm/tools/mach-types
-+++ linux-4.0-rc4/arch/arm/tools/mach-types
+--- a/arch/arm/tools/mach-types
++++ b/arch/arm/tools/mach-types
@@ -228,6 +228,7 @@ edb9302a MACH_EDB9302A EDB9302A 1127
edb9307a MACH_EDB9307A EDB9307A 1128
omap_3430sdp MACH_OMAP_3430SDP OMAP_3430SDP 1138
@@ -65,10 +57,8 @@ Index: linux-4.0-rc4/arch/arm/tools/mach-types
micro9m MACH_MICRO9M MICRO9M 1169
bug MACH_BUG BUG 1179
at91sam9263ek MACH_AT91SAM9263EK AT91SAM9263EK 1202
-Index: linux-4.0-rc4/drivers/clk/Makefile
-===================================================================
---- linux-4.0-rc4.orig/drivers/clk/Makefile
-+++ linux-4.0-rc4/drivers/clk/Makefile
+--- a/drivers/clk/Makefile
++++ b/drivers/clk/Makefile
@@ -31,6 +31,7 @@ obj-$(CONFIG_COMMON_CLK_MAX77802) += clk
obj-$(CONFIG_ARCH_MOXART) += clk-moxart.o
obj-$(CONFIG_ARCH_NOMADIK) += clk-nomadik.o