aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/orion/patches/200-dt2_board_support.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-06-04 11:29:01 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-06-04 11:29:01 +0000
commit64b5929539344c5b9741155c0f9454374eac1e89 (patch)
tree315a63e65ef11123acc3f843ffa8f11697bd8c46 /target/linux/orion/patches/200-dt2_board_support.patch
parent6a9bdec862947980a7cfd4bbf38c62df2e0ba7b5 (diff)
downloadmaster-187ad058-64b5929539344c5b9741155c0f9454374eac1e89.tar.gz
master-187ad058-64b5929539344c5b9741155c0f9454374eac1e89.tar.bz2
master-187ad058-64b5929539344c5b9741155c0f9454374eac1e89.zip
[orion]: versioned files and dirs still make no sense when you support only a single kernel...
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36836 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/orion/patches/200-dt2_board_support.patch')
-rw-r--r--target/linux/orion/patches/200-dt2_board_support.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/orion/patches/200-dt2_board_support.patch b/target/linux/orion/patches/200-dt2_board_support.patch
new file mode 100644
index 0000000000..91909abac0
--- /dev/null
+++ b/target/linux/orion/patches/200-dt2_board_support.patch
@@ -0,0 +1,26 @@
+--- a/arch/arm/mach-orion5x/Kconfig
++++ b/arch/arm/mach-orion5x/Kconfig
+@@ -16,6 +16,13 @@ config MACH_RD88F5182
+ Say 'Y' here if you want your kernel to support the
+ Marvell Orion-NAS (88F5182) RD2
+
++config MACH_DT2
++ bool "Freecom DataTank Gateway"
++ select I2C_BOARDINFO
++ help
++ Say 'Y' here if you want your kernel to support the
++ Freecom DataTank Gateway
++
+ config MACH_KUROBOX_PRO
+ bool "KuroBox Pro"
+ select I2C_BOARDINFO
+--- a/arch/arm/mach-orion5x/Makefile
++++ b/arch/arm/mach-orion5x/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_MACH_BIGDISK) += d2net-setu
+ obj-$(CONFIG_MACH_NET2BIG) += net2big-setup.o
+ obj-$(CONFIG_MACH_MSS2) += mss2-setup.o
+ obj-$(CONFIG_MACH_WNR854T) += wnr854t-setup.o
++obj-$(CONFIG_MACH_DT2) += dt2-setup.o
+ obj-$(CONFIG_MACH_RD88F5181L_GE) += rd88f5181l-ge-setup.o
+ obj-$(CONFIG_MACH_RD88F5181L_FXO) += rd88f5181l-fxo-setup.o
+ obj-$(CONFIG_MACH_RD88F6183AP_GE) += rd88f6183ap-ge-setup.o