aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/orion/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-06-04 13:51:17 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-06-04 13:51:17 +0000
commit588d69a7c7bdd5051d3bf1362eeef3b11a9ca901 (patch)
treeb23043472ad11463f5e978310b30d1cebd104bb1 /target/linux/orion/Makefile
parent95866983cafe3812b267f795759ad5980720e6f7 (diff)
downloadmaster-187ad058-588d69a7c7bdd5051d3bf1362eeef3b11a9ca901.tar.gz
master-187ad058-588d69a7c7bdd5051d3bf1362eeef3b11a9ca901.tar.bz2
master-187ad058-588d69a7c7bdd5051d3bf1362eeef3b11a9ca901.zip
add preliminary Marvell Orion support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11352 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/orion/Makefile')
-rw-r--r--target/linux/orion/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/orion/Makefile b/target/linux/orion/Makefile
new file mode 100644
index 0000000000..4cc509ad28
--- /dev/null
+++ b/target/linux/orion/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=orion
+BOARDNAME:=Marvell Orion
+FEATURES:=squashfs
+
+LINUX_VERSION:=2.6.26-rc4
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="uImage"
+
+DEFAULT_PACKAGES += kmod-madwifi
+
+define Kernel/Configure
+ $(call Kernel/Configure/Default)
+ $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
+ $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
+endef
+
+$(eval $(call BuildTarget))