aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap35xx/gumstix/profiles
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2011-03-10 10:37:02 +0000
committerHamish Guthrie <hcg@openwrt.org>2011-03-10 10:37:02 +0000
commit3d9cd1095481949c0e7803bd553581156d6ab5f0 (patch)
treecc4a4d0d19fa060ac3e7b77537f6d23e862faa2e /target/linux/omap35xx/gumstix/profiles
parentda9cae627adec10330e1d688e01c4db597765257 (diff)
downloadmaster-187ad058-3d9cd1095481949c0e7803bd553581156d6ab5f0.tar.gz
master-187ad058-3d9cd1095481949c0e7803bd553581156d6ab5f0.tar.bz2
master-187ad058-3d9cd1095481949c0e7803bd553581156d6ab5f0.zip
Add new profile for vpp platform
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25997 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/omap35xx/gumstix/profiles')
-rw-r--r--target/linux/omap35xx/gumstix/profiles/000-hegw.mk (renamed from target/linux/omap35xx/gumstix/profiles/gumstix.mk)2
-rw-r--r--target/linux/omap35xx/gumstix/profiles/001-vpp.mk29
2 files changed, 30 insertions, 1 deletions
diff --git a/target/linux/omap35xx/gumstix/profiles/gumstix.mk b/target/linux/omap35xx/gumstix/profiles/000-hegw.mk
index 0b82ec1a60..9ff7fadab8 100644
--- a/target/linux/omap35xx/gumstix/profiles/gumstix.mk
+++ b/target/linux/omap35xx/gumstix/profiles/000-hegw.mk
@@ -8,7 +8,7 @@
FEATURES:=ubifs
define Profile/Gumstix
- NAME:=gumstix
+ NAME:=hegw
PACKAGES:=-iptables -ppp -ppp-mod-pppoe -kmod-ipt-nathelper \
-firewall -mtd -hotplug2 -udevtrigger -dropbear \
ext4 ubifs usb udev kmod-bluetooth ntpclient wpa-supplicant \
diff --git a/target/linux/omap35xx/gumstix/profiles/001-vpp.mk b/target/linux/omap35xx/gumstix/profiles/001-vpp.mk
new file mode 100644
index 0000000000..bf7c480ef0
--- /dev/null
+++ b/target/linux/omap35xx/gumstix/profiles/001-vpp.mk
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+FEATURES:=ubifs
+
+define Profile/Vpp
+ NAME:=vpp
+ PACKAGES:=-iptables -ppp -ppp-mod-pppoe -kmod-ipt-nathelper \
+ -firewall -mtd -hotplug2 -udevtrigger -dropbear \
+ ext4 ubifs usb udev kmod-bluetooth ntpclient wpa-supplicant \
+ wireless-tools wpa-cli \
+ bluez-utils bluez-hcidump usbutils \
+ kmod-usb-serial kmod-usb-serial-cp210x kmod-usb-serial-ftdi \
+ kmod-usb-serial-pl2303 kmod-usb-uhci kmod-cfg80211 \
+ kmod-lib80211 kmod-libertas-sd kmod-mac80211 libnl-tiny \
+ crda iw kmod-usb-hid \
+ kmod-usb-storage kmod-usb-storage-extras kmod-fs-vfat \
+ uboot-omap35xx-omap3_overo \
+ hegw hegwtest mtd-utils ejre
+endef
+
+define Profile/Vpp/Description
+ Gumstix www.gumstix.com
+endef
+$(eval $(call Profile,Vpp))