aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-06-02 09:18:55 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-06-02 09:18:55 +0000
commit73ee9b875e79eef94be74887b01269f890a0c220 (patch)
tree9e8c67b83aca0ea417fb01dee5412333c3a0cb93 /target/linux/octeon/image
parentae9fd50c01e575b39b491f84376ced2a19d56e28 (diff)
downloadmaster-187ad058-73ee9b875e79eef94be74887b01269f890a0c220.tar.gz
master-187ad058-73ee9b875e79eef94be74887b01269f890a0c220.tar.bz2
master-187ad058-73ee9b875e79eef94be74887b01269f890a0c220.zip
rename cavium-octeon to octeon
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16292 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/octeon/image')
-rw-r--r--target/linux/octeon/image/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
new file mode 100644
index 0000000000..7189a9cffa
--- /dev/null
+++ b/target/linux/octeon/image/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ # Workaround pre-SDK-1.9.0 u-boot versions not handling the .notes section
+ $(TARGET_CROSS)strip -R .notes $(KDIR)/vmlinux.elf -o $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
+ dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma bs=65536 conv=sync
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ $(call Image/Build/$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+endef
+
+$(eval $(call BuildImage))