aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2016-02-17 17:49:26 +0000
committerLuka Perkov <luka@openwrt.org>2016-02-17 17:49:26 +0000
commit8572bdb5afd4fe83958069baa0d114ca54509369 (patch)
tree55aaaa86672cecf0cbf04ada954d85897c27e61c /target/linux/mvebu/image/Makefile
parent0324831e9e5a361ef570a9b022ee2c1f5e508c6a (diff)
downloadmaster-187ad058-8572bdb5afd4fe83958069baa0d114ca54509369.tar.gz
master-187ad058-8572bdb5afd4fe83958069baa0d114ca54509369.tar.bz2
master-187ad058-8572bdb5afd4fe83958069baa0d114ca54509369.zip
mvebu: add SolidRun ClearFog A1 support
Signed-off-by: Andrej Vlasic <andrej.vlasic@sartura.hr> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48736 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mvebu/image/Makefile')
-rw-r--r--target/linux/mvebu/image/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 123be9eac2..cb73c3bea6 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -98,6 +98,26 @@ define NORProfile
endef
# $(1): Profile Name
+# $(2): DTB Name
+define MMCProfile
+ define Image/BuildKernel/Profile/$(1)
+ $(call Image/Build/DTB,$(2))
+ cp $(KDIR)/zImage-$(2) $(BIN_DIR)/zImage-$(1);
+ cp $(DTS_DIR)/$(2).dtb $(BIN_DIR)/$(1).dtb;
+ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+ $(call Image/Build/Profile,$(1)/Initramfs)
+ endif
+ endef
+
+ define Image/Build/Profile/$(1)/Initramfs
+ $(call Image/Build/DTB,$(2),-initramfs)
+ cp $(KDIR)/uImage-initramfs-$(2) $(BIN_DIR)/$(IMG_PREFIX)-$(2)-initramfs
+ endef
+
+ PROFILES_LIST += $(1)
+endef
+
+# $(1): Profile Name
# $(2): Sub Profiles list
define MultiProfile
define Image/BuildKernel/Profile/$(1)
@@ -141,6 +161,8 @@ $(eval $(call UBINORProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB)
# Boards with small NOR, where UBI doesn't make sense
$(eval $(call NORProfile,388-RD,armada-388-rd,256KiB))
+$(eval $(call MMCProfile,Solidrun-Clearfog-A1,armada-388-clearfog))
+
###
### Linksys
###