aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/image/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-10-08 10:01:30 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-10-08 10:01:30 +0000
commit702a54a6612d89d372364501c9f05052b18a4a17 (patch)
treec8b3105a89af3de08f10c66c2b3f547be3238195 /target/linux/mvebu/image/Makefile
parentff10ea53ec3a3451fd03331d11790ff98fd312a7 (diff)
downloadmaster-187ad058-702a54a6612d89d372364501c9f05052b18a4a17.tar.gz
master-187ad058-702a54a6612d89d372364501c9f05052b18a4a17.tar.bz2
master-187ad058-702a54a6612d89d372364501c9f05052b18a4a17.zip
mvebu: add support for the Linksys WRT1900ACS (Shelby)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47164 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mvebu/image/Makefile')
-rw-r--r--target/linux/mvebu/image/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 7f270dd530..20a7ac14da 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -133,6 +133,7 @@ $(eval $(call NANDProfile,XP-GP,armada-xp-gp,512KiB,4096))
$(eval $(call NANDProfile,Mamba,armada-xp-linksys-mamba,128KiB,2048,512,2048))
$(eval $(call NANDProfile,Caiman,armada-385-linksys-caiman,128KiB,2048,512,2048))
$(eval $(call NANDProfile,Cobra,armada-385-linksys-cobra,128KiB,2048,512,2048))
+$(eval $(call NANDProfile,Shelby,armada-385-linksys-shelby,128KiB,2048,512,2048))
# Boards with large NOR, where we want to use UBI
$(eval $(call UBINORProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB))
@@ -174,6 +175,16 @@ define Image/Build/Profile/Mamba/squashfs
) > $(BIN_DIR)/$(IMG_PREFIX)-armada-xp-linksys-mamba-squashfs-factory.img
endef
+# Shelby: Linksys WRT1900ACS
+define Image/Build/Profile/Shelby/squashfs
+ $(call Image/Build/UbinizeImage,armada-385-linksys-shelby,,squashfs, -p 128KiB -m 2048 -s 512 -O 2048)
+ ( \
+ dd if=$(KDIR)/uImage-armada-385-linksys-shelby bs=6M conv=sync; \
+ dd if=$(KDIR)/$(IMG_PREFIX)-armada-385-linksys-shelby-squashfs-ubinized.bin \
+ bs=2048 conv=sync; \
+ ) > $(BIN_DIR)/$(IMG_PREFIX)-armada-385-linksys-shelby-squashfs-factory.img
+endef
+
###
### Marvell
###