aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc83xx
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-06-27 19:58:31 +0000
commit704e2ed39d4e157d0c24d4dc3a3078cbacc6505c (patch)
treeffba1790b89941519ddb5acc2bf8f55df6b65529 /target/linux/mpc83xx
parent5431c1983b51e4f69db63f5d5c94b2ed157e5374 (diff)
downloadmaster-187ad058-704e2ed39d4e157d0c24d4dc3a3078cbacc6505c.tar.gz
master-187ad058-704e2ed39d4e157d0c24d4dc3a3078cbacc6505c.tar.bz2
master-187ad058-704e2ed39d4e157d0c24d4dc3a3078cbacc6505c.zip
targets: prepare for supporting normal and initramfs images
In order to support both normal images and initramfs, ensure that each target sets KERNELNAME properly so that the generic kernel building code can copy the corresponding files over $(KDIR) with the appropriate extension. Update the various paths to the kernel and wrapper images from $(LINUX_DIR)/arch/$(ARCH)/boot/$(foo) to $(KDIR)/$(foo). Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37049 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mpc83xx')
-rw-r--r--target/linux/mpc83xx/Makefile2
-rw-r--r--target/linux/mpc83xx/image/Makefile2
2 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/mpc83xx/Makefile b/target/linux/mpc83xx/Makefile
index bc52368f06..2a721dace0 100644
--- a/target/linux/mpc83xx/Makefile
+++ b/target/linux/mpc83xx/Makefile
@@ -23,4 +23,6 @@ define Target/Description
Build firmware images for Freescale MPC83xx based boards (eg. RouterBoard 600).
endef
+KERNELNAME:="uImage"
+
$(eval $(call BuildTarget))
diff --git a/target/linux/mpc83xx/image/Makefile b/target/linux/mpc83xx/image/Makefile
index aabfbad4d1..c7458f1c24 100644
--- a/target/linux/mpc83xx/image/Makefile
+++ b/target/linux/mpc83xx/image/Makefile
@@ -15,7 +15,7 @@ endef
define Image/BuildKernel
cp $(LINUX_DIR)/arch/powerpc/boot/dtbImage.rb600.elf $(BIN_DIR)/openwrt-$(BOARD)-rb600.elf
cp $(LINUX_DIR)/arch/powerpc/boot/dtbImage.rb333.elf $(BIN_DIR)/openwrt-$(BOARD)-rb333.elf
- cp $(LINUX_DIR)/arch/powerpc/boot/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
endef
define Image/Build