aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-11-02 10:18:50 +0000
committerJohn Crispin <blogic@openwrt.org>2015-11-02 10:18:50 +0000
commit20e347390b78de3f0a701e077aa1a69dd0977ec1 (patch)
treedd684baeca3d31c464be1095df76fb19a6e32f21 /target/linux/mediatek/image
parentcc6f9d1ab21bfe54f1f1193f3146da9444b42dde (diff)
downloadmaster-187ad058-20e347390b78de3f0a701e077aa1a69dd0977ec1.tar.gz
master-187ad058-20e347390b78de3f0a701e077aa1a69dd0977ec1.tar.bz2
master-187ad058-20e347390b78de3f0a701e077aa1a69dd0977ec1.zip
mediatek: add support for the new MT7623 Arm SoC
the support is still WIP. next steps are to make the pmic and ethernet work. this is the first commit to make sure nothing gets lost. Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47354 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mediatek/image')
-rw-r--r--target/linux/mediatek/image/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/mediatek/image/Makefile b/target/linux/mediatek/image/Makefile
new file mode 100644
index 0000000000..82525c9b37
--- /dev/null
+++ b/target/linux/mediatek/image/Makefile
@@ -0,0 +1,28 @@
+# Copyright (c) 2014 The Linux Foundation. All rights reserved.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuilduImage
+ cat $(LINUX_DIR)/arch/arm/boot/dts/mt7623-evb.dtb >> $(KDIR)/zImage$(1)
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/zImage$(1) $(KDIR)/zImage$(1).lzma
+ mkimage -A arm -O linux -T kernel -C lzma -a 0x80008000 -e 0x80008000 -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage$(1).lzma $(KDIR)/uImage$(1)
+ $(CP) $(KDIR)/uImage$(1) $(BIN_DIR)/$(IMG_PREFIX)-uImage$(1)
+endef
+
+define Image/BuildKernel
+ $(call Image/BuilduImage)
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
+ $(call Image/BuilduImage,-initramfs)
+endif
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+$(eval $(call BuildImage))