aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mediatek/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-11-02 10:18:50 +0000
committerJohn Crispin <blogic@openwrt.org>2015-11-02 10:18:50 +0000
commit20e347390b78de3f0a701e077aa1a69dd0977ec1 (patch)
treedd684baeca3d31c464be1095df76fb19a6e32f21 /target/linux/mediatek/Makefile
parentcc6f9d1ab21bfe54f1f1193f3146da9444b42dde (diff)
downloadmaster-187ad058-20e347390b78de3f0a701e077aa1a69dd0977ec1.tar.gz
master-187ad058-20e347390b78de3f0a701e077aa1a69dd0977ec1.tar.bz2
master-187ad058-20e347390b78de3f0a701e077aa1a69dd0977ec1.zip
mediatek: add support for the new MT7623 Arm SoC
the support is still WIP. next steps are to make the pmic and ethernet work. this is the first commit to make sure nothing gets lost. Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47354 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mediatek/Makefile')
-rw-r--r--target/linux/mediatek/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/mediatek/Makefile b/target/linux/mediatek/Makefile
new file mode 100644
index 0000000000..d0b266b12f
--- /dev/null
+++ b/target/linux/mediatek/Makefile
@@ -0,0 +1,20 @@
+# Copyright (c) 2015 OpenWrt.org
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=mediatek
+BOARDNAME:=Mediatek Ralink ARM
+FEATURES:=squashfs
+CPU_TYPE:=cortex-a7
+MAINTAINER:=John Crispin <blogic@openwrt.org>
+
+KERNEL_PATCHVER:=4.1
+
+KERNELNAME:=Image dtbs zImage
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+ kmod-leds-gpio kmod-gpio-button-hotplug swconfig
+
+$(eval $(call BuildTarget))