aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/patches-3.3/001-platform.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-06-19 14:48:56 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-06-19 14:48:56 +0000
commitfea5404e8a8b3d0190c8386f190b723477acebd4 (patch)
tree7b34e2be994fc0c2bdd15a6868864b39be34d6bc /target/linux/mcs814x/patches-3.3/001-platform.patch
parent208fa63215795719b6875e7f5bc2090400c5ea1e (diff)
downloadmaster-187ad058-fea5404e8a8b3d0190c8386f190b723477acebd4.tar.gz
master-187ad058-fea5404e8a8b3d0190c8386f190b723477acebd4.tar.bz2
master-187ad058-fea5404e8a8b3d0190c8386f190b723477acebd4.zip
[mcs814x] add Moschip MSC814x support
This target currently only supports Moschip's MCS8140 SoC, but support for other chips in the same family (MCS8142, MCS8144) will be easy to add. Target support is entirely using Device Tree for probing peripherals. Drivers support include: - PCI - USB 1 & 2 - watchdog - random number generator - UART - timer - internal Ethernet PHY - Ethernet MAC core Support for the following boards is included using Device Tree - Devolo dLAN USB Extender - Tigal RBT-832 git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32462 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mcs814x/patches-3.3/001-platform.patch')
-rw-r--r--target/linux/mcs814x/patches-3.3/001-platform.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/target/linux/mcs814x/patches-3.3/001-platform.patch b/target/linux/mcs814x/patches-3.3/001-platform.patch
new file mode 100644
index 0000000000..dc153a5d4e
--- /dev/null
+++ b/target/linux/mcs814x/patches-3.3/001-platform.patch
@@ -0,0 +1,43 @@
+--- a/arch/arm/Kconfig
++++ b/arch/arm/Kconfig
+@@ -869,6 +869,21 @@ config ARCH_EXYNOS
+ help
+ Support for SAMSUNG's EXYNOS SoCs (EXYNOS4/5)
+
++config ARCH_MCS814X
++ bool "Moschip MCS814x"
++ select CPU_ARM926T
++ select PCI
++ select FIQ
++ select GENERIC_IRQ_CHIP
++ select GENERIC_GPIO
++ select ARCH_REQUIRE_GPIOLIB
++ select CLKDEV_LOOKUP
++ select ARCH_USES_GETTIMEOFFSET
++ select NEED_MACH_MEMORY_H
++ select MULTI_IRQ_HANDLER
++ help
++ Support for Moschip MCS814x SoCs (MCS8140).
++
+ config ARCH_SHARK
+ bool "Shark"
+ select CPU_SA110
+@@ -1065,6 +1080,8 @@ source "arch/arm/plat-samsung/Kconfig"
+ source "arch/arm/plat-s3c24xx/Kconfig"
+ source "arch/arm/plat-s5p/Kconfig"
+
++source "arch/arm/mach-mcs814x/Kconfig"
++
+ source "arch/arm/plat-spear/Kconfig"
+
+ if ARCH_S3C2410
+--- a/arch/arm/Makefile
++++ b/arch/arm/Makefile
+@@ -179,6 +179,7 @@ machine-$(CONFIG_ARCH_S3C64XX) := s3c64
+ machine-$(CONFIG_ARCH_S5P64X0) := s5p64x0
+ machine-$(CONFIG_ARCH_S5PC100) := s5pc100
+ machine-$(CONFIG_ARCH_S5PV210) := s5pv210
++machine-$(CONFIG_ARCH_MCS814X) := mcs814x
+ machine-$(CONFIG_ARCH_EXYNOS4) := exynos
+ machine-$(CONFIG_ARCH_SA1100) := sa1100
+ machine-$(CONFIG_ARCH_SHARK) := shark