aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/patches-3.18/011-mcs814x_internal_phy.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2015-04-04 18:01:07 +0000
committerFlorian Fainelli <florian@openwrt.org>2015-04-04 18:01:07 +0000
commitd030e21a01634dd74b84b4b1de55fe1a86ad1a15 (patch)
treea06c2ec374a34c9b7fff6551e596e381eb87e263 /target/linux/mcs814x/patches-3.18/011-mcs814x_internal_phy.patch
parent71f35a88e4666f4f310efb4563ebfce54045636f (diff)
downloadmaster-187ad058-d030e21a01634dd74b84b4b1de55fe1a86ad1a15.tar.gz
master-187ad058-d030e21a01634dd74b84b4b1de55fe1a86ad1a15.tar.bz2
master-187ad058-d030e21a01634dd74b84b4b1de55fe1a86ad1a15.zip
mcs814x: add support for 3.18
Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45273 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mcs814x/patches-3.18/011-mcs814x_internal_phy.patch')
-rw-r--r--target/linux/mcs814x/patches-3.18/011-mcs814x_internal_phy.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/mcs814x/patches-3.18/011-mcs814x_internal_phy.patch b/target/linux/mcs814x/patches-3.18/011-mcs814x_internal_phy.patch
new file mode 100644
index 0000000000..20d5add206
--- /dev/null
+++ b/target/linux/mcs814x/patches-3.18/011-mcs814x_internal_phy.patch
@@ -0,0 +1,20 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -164,6 +164,10 @@ config RTL8306_PHY
+ tristate "Driver for Realtek RTL8306S switches"
+ select SWCONFIG
+
++config MCS814X_PHY
++ tristate "Driver for the Moschip MCS814x internal PHY"
++ depends on ARCH_MCS814X
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -51,3 +51,4 @@ obj-$(CONFIG_MDIO_SUN4I) += mdio-sun4i.o
+ obj-$(CONFIG_MDIO_MOXART) += mdio-moxart.o
+ obj-$(CONFIG_AMD_XGBE_PHY) += amd-xgbe-phy.o
+ obj-$(CONFIG_MDIO_BCM_UNIMAC) += mdio-bcm-unimac.o
++obj-$(CONFIG_MCS814X_PHY) += mcs814x.o