aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/patches-3.18/003-ethernet.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2015-04-04 18:01:07 +0000
committerFlorian Fainelli <florian@openwrt.org>2015-04-04 18:01:07 +0000
commitd030e21a01634dd74b84b4b1de55fe1a86ad1a15 (patch)
treea06c2ec374a34c9b7fff6551e596e381eb87e263 /target/linux/mcs814x/patches-3.18/003-ethernet.patch
parent71f35a88e4666f4f310efb4563ebfce54045636f (diff)
downloadmaster-187ad058-d030e21a01634dd74b84b4b1de55fe1a86ad1a15.tar.gz
master-187ad058-d030e21a01634dd74b84b4b1de55fe1a86ad1a15.tar.bz2
master-187ad058-d030e21a01634dd74b84b4b1de55fe1a86ad1a15.zip
mcs814x: add support for 3.18
Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45273 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mcs814x/patches-3.18/003-ethernet.patch')
-rw-r--r--target/linux/mcs814x/patches-3.18/003-ethernet.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/mcs814x/patches-3.18/003-ethernet.patch b/target/linux/mcs814x/patches-3.18/003-ethernet.patch
new file mode 100644
index 0000000000..3ee8cd6b35
--- /dev/null
+++ b/target/linux/mcs814x/patches-3.18/003-ethernet.patch
@@ -0,0 +1,16 @@
+--- a/drivers/net/ethernet/Kconfig
++++ b/drivers/net/ethernet/Kconfig
+@@ -186,4 +186,6 @@ source "drivers/net/ethernet/wiznet/Kcon
+ source "drivers/net/ethernet/xilinx/Kconfig"
+ source "drivers/net/ethernet/xircom/Kconfig"
+
++source "drivers/net/ethernet/mcs8140/Kconfig"
++
+ endif # ETHERNET
+--- a/drivers/net/ethernet/Makefile
++++ b/drivers/net/ethernet/Makefile
+@@ -84,3 +84,4 @@ obj-$(CONFIG_NET_VENDOR_VIA) += via/
+ obj-$(CONFIG_NET_VENDOR_WIZNET) += wiznet/
+ obj-$(CONFIG_NET_VENDOR_XILINX) += xilinx/
+ obj-$(CONFIG_NET_VENDOR_XIRCOM) += xircom/
++obj-$(CONFIG_NUPORT_ETHERNET_DRIVER) += mcs8140/