aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-08-17 06:16:19 +0000
committerJohn Crispin <blogic@openwrt.org>2015-08-17 06:16:19 +0000
commitaff7fef99673b65fce30e613618ee11f4cb8f7b6 (patch)
treeaefdddb472782b5cdc8790e15ddf9d65fccd3f23 /target/linux/mcs814x/image
parentf4340c5f169975b5a3b44c16a5d717b23fefa614 (diff)
downloadmaster-187ad058-aff7fef99673b65fce30e613618ee11f4cb8f7b6.tar.gz
master-187ad058-aff7fef99673b65fce30e613618ee11f4cb8f7b6.tar.bz2
master-187ad058-aff7fef99673b65fce30e613618ee11f4cb8f7b6.zip
mcs814x: use firmware partition splitter on dLAN USB Extender
to avoid editing the dts every time the kernel size changes. uImage is now bigger than 1MB. Pad uImage to 64k erase block size. Signed-off-by: Günther Kelleter <guenther.kelleter@devolo.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46648 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mcs814x/image')
-rw-r--r--target/linux/mcs814x/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/mcs814x/image/Makefile b/target/linux/mcs814x/image/Makefile
index 017a564f09..3afd660c14 100644
--- a/target/linux/mcs814x/image/Makefile
+++ b/target/linux/mcs814x/image/Makefile
@@ -31,7 +31,7 @@ define Image/Build/DTB
endef
define Image/Build/Profile/dLAN_USB_Extender
- dd if=$(KDIR)/uImage-dlan-usb-extender bs=1M conv=sync of=$(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
+ dd if=$(KDIR)/uImage-dlan-usb-extender bs=64k conv=sync of=$(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
cat $(KDIR)/root.$(1) >> $(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
cp $(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin $(BIN_DIR)/
endef