aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/magicbox/image/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-11-26 10:06:34 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-11-26 10:06:34 +0000
commit0eb1e059baaaa3054e38ba046c50f702e246053e (patch)
tree8d27069f3352e5274a253fafb87812df4d1e3d3e /target/linux/magicbox/image/Makefile
parent38b1737377cefbde769259b62414cc2c820ee7c8 (diff)
downloadmaster-187ad058-0eb1e059baaaa3054e38ba046c50f702e246053e.tar.gz
master-187ad058-0eb1e059baaaa3054e38ba046c50f702e246053e.tar.bz2
master-187ad058-0eb1e059baaaa3054e38ba046c50f702e246053e.zip
nuke the magicbox target and incorporate a rewritten port into ppc40x - note: no CF driver for now
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13358 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/magicbox/image/Makefile')
-rw-r--r--target/linux/magicbox/image/Makefile37
1 files changed, 0 insertions, 37 deletions
diff --git a/target/linux/magicbox/image/Makefile b/target/linux/magicbox/image/Makefile
deleted file mode 100644
index edae68a266..0000000000
--- a/target/linux/magicbox/image/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
-
-define Image/Prepare
- cp $(LINUX_DIR)/arch/ppc/boot/images/uImage $(KDIR)/uImage
-endef
-
-define Image/BuildKernel
- cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
-endef
-
-define Image/Build
- $(call Image/Build/$(1),$(1))
-endef
-
-define Image/Build/jffs2-64k
- ( \
- dd if=$(KDIR)/uImage bs=1024k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=65536 conv=sync; \
- ) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
-endef
-
-define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
- ( \
- dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=1024k conv=sync; \
- dd if=$(KDIR)/root.$(1) bs=65536 conv=sync; \
- ) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
-endef
-
-$(eval $(call BuildImage))