aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-12-19 15:17:31 +0000
committerJohn Crispin <blogic@openwrt.org>2012-12-19 15:17:31 +0000
commitbfed5c6801fb82bbd81c7c46663d9c30939b1e55 (patch)
tree8fb105263a45026236a19725d17c71d781353bee /target/linux/lantiq
parentcb8fc67686dd046a3134f5a2b08c33ff120ba35f (diff)
downloadmaster-187ad058-bfed5c6801fb82bbd81c7c46663d9c30939b1e55.tar.gz
master-187ad058-bfed5c6801fb82bbd81c7c46663d9c30939b1e55.tar.bz2
master-187ad058-bfed5c6801fb82bbd81c7c46663d9c30939b1e55.zip
[lantiq] fix gptu clocks
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34789 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/patches-3.7/0301-gptu.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/lantiq/patches-3.7/0301-gptu.patch b/target/linux/lantiq/patches-3.7/0301-gptu.patch
index 4539d4a338..33fb0fb86c 100644
--- a/target/linux/lantiq/patches-3.7/0301-gptu.patch
+++ b/target/linux/lantiq/patches-3.7/0301-gptu.patch
@@ -1,7 +1,7 @@
Index: linux-3.7.1/arch/mips/lantiq/xway/timer.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.7.1/arch/mips/lantiq/xway/timer.c 2012-12-18 20:47:56.625037132 +0100
++++ linux-3.7.1/arch/mips/lantiq/xway/timer.c 2012-12-18 22:24:36.133175326 +0100
@@ -0,0 +1,841 @@
+#include <linux/kernel.h>
+#include <linux/module.h>
@@ -216,7 +216,7 @@ Index: linux-3.7.1/arch/mips/lantiq/xway/timer.c
+
+static inline void lq_enable_gptu(void)
+{
-+ struct clk *clk = clk_get_sys("ltq_gptu", NULL);
++ struct clk *clk = clk_get_sys("1e100a00.gptu", NULL);
+ clk_enable(clk);
+
+ //ltq_pmu_enable(PMU_GPT);
@@ -234,7 +234,7 @@ Index: linux-3.7.1/arch/mips/lantiq/xway/timer.c
+
+static inline void lq_disable_gptu(void)
+{
-+ struct clk *clk = clk_get_sys("ltq_gptu", NULL);
++ struct clk *clk = clk_get_sys("1e100a00.gptu", NULL);
+ ltq_w32(0x00, LQ_GPTU_IRNEN);
+ ltq_w32(0xfff, LQ_GPTU_IRNCR);
+
@@ -1007,7 +1007,7 @@ Index: linux-3.7.1/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
Index: linux-3.7.1/arch/mips/lantiq/xway/Makefile
===================================================================
--- linux-3.7.1.orig/arch/mips/lantiq/xway/Makefile 2012-12-18 20:48:40.717038183 +0100
-+++ linux-3.7.1/arch/mips/lantiq/xway/Makefile 2012-12-18 20:49:10.129038884 +0100
++++ linux-3.7.1/arch/mips/lantiq/xway/Makefile 2012-12-18 22:24:48.965175632 +0100
@@ -1,3 +1,3 @@
-obj-y := prom.o sysctrl.o clk.o reset.o dma.o gptu.o dcdc.o
+obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o