aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-12-16 10:03:18 +0000
committerJohn Crispin <blogic@openwrt.org>2012-12-16 10:03:18 +0000
commitbcb1d9c43baf17e0cb09a2d3c6af13d07ee45d57 (patch)
tree22f3920523292b8413b228fbcbd5d7ae1ac72c1c /target/linux/lantiq
parent84b15c53856b2801faf77d74d8ae8d1a419d64f2 (diff)
downloadmaster-187ad058-bcb1d9c43baf17e0cb09a2d3c6af13d07ee45d57.tar.gz
master-187ad058-bcb1d9c43baf17e0cb09a2d3c6af13d07ee45d57.tar.bz2
master-187ad058-bcb1d9c43baf17e0cb09a2d3c6af13d07ee45d57.zip
[lantiq] fix i2c-lantiq module
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34712 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/modules.mk18
1 files changed, 9 insertions, 9 deletions
diff --git a/target/linux/lantiq/modules.mk b/target/linux/lantiq/modules.mk
index 9022318703..e7fbad3a29 100644
--- a/target/linux/lantiq/modules.mk
+++ b/target/linux/lantiq/modules.mk
@@ -5,18 +5,18 @@
# See /LICENSE for more information.
#
-I2C_FALCON_MODULES:= \
- CONFIG_I2C_FALCON:drivers/i2c/busses/i2c-falcon
+I2C_LANTIQ_MODULES:= \
+ CONFIG_I2C_LANTIQ:drivers/i2c/busses/i2c-lantiq
-define KernelPackage/i2c-falcon-lantiq
- TITLE:=Falcon I2C controller
- $(call i2c_defaults,$(I2C_FALCON_MODULES),52)
- DEPENDS:=kmod-i2c-core @(TARGET_lantiq_falcon||TARGET_lantiq_falcon_stable)
+define KernelPackage/i2c-lantiq
+ TITLE:=Lantiq I2C controller
+ $(call i2c_defaults,$(I2C_LANTIQ_MODULES),52)
+ DEPENDS:=kmod-i2c-core @TARGET_lantiq_falcon
endef
-define KernelPackage/i2c-falcon-lantiq/description
- Kernel support for the Falcon I2C controller
+define KernelPackage/i2c-lantiq/description
+ Kernel support for the Lantiq/Falcon I2C controller
endef
-$(eval $(call KernelPackage,i2c-falcon-lantiq))
+$(eval $(call KernelPackage,i2c-lantiq))