aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-3.8/0027-NET-PHY-adds-driver-for-lantiq-PHY11G.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-03-15 14:39:51 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-03-15 14:39:51 +0000
commit84da5668735a12ef1a36eeb6777c37cd0de63ef9 (patch)
tree8417e7b50ec23e10ee0678ad5b4f032260cc6b2a /target/linux/lantiq/patches-3.8/0027-NET-PHY-adds-driver-for-lantiq-PHY11G.patch
parent257aff3780d895c15f710ee10edeeb9c04e97ed1 (diff)
downloadmaster-187ad058-84da5668735a12ef1a36eeb6777c37cd0de63ef9.tar.gz
master-187ad058-84da5668735a12ef1a36eeb6777c37cd0de63ef9.tar.bz2
master-187ad058-84da5668735a12ef1a36eeb6777c37cd0de63ef9.zip
kernel: update linux 3.8 to 3.8.3
Also refresh the related generic/platform patches. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36039 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/patches-3.8/0027-NET-PHY-adds-driver-for-lantiq-PHY11G.patch')
-rw-r--r--target/linux/lantiq/patches-3.8/0027-NET-PHY-adds-driver-for-lantiq-PHY11G.patch16
1 files changed, 3 insertions, 13 deletions
diff --git a/target/linux/lantiq/patches-3.8/0027-NET-PHY-adds-driver-for-lantiq-PHY11G.patch b/target/linux/lantiq/patches-3.8/0027-NET-PHY-adds-driver-for-lantiq-PHY11G.patch
index 5250377c0a..b1aefa20d6 100644
--- a/target/linux/lantiq/patches-3.8/0027-NET-PHY-adds-driver-for-lantiq-PHY11G.patch
+++ b/target/linux/lantiq/patches-3.8/0027-NET-PHY-adds-driver-for-lantiq-PHY11G.patch
@@ -11,13 +11,11 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
3 files changed, 226 insertions(+)
create mode 100644 drivers/net/phy/lantiq.c
-diff --git a/drivers/net/phy/Kconfig b/drivers/net/phy/Kconfig
-index 961f0b2..41a2992 100644
--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
-@@ -107,6 +107,11 @@ config MICREL_PHY
+@@ -150,6 +150,11 @@ config MICREL_PHY
---help---
- Supports the KSZ9021, VSC8201, KS8001 PHYs.
+ Currently has a driver for the KSZ8041
+config LANTIQ_PHY
+ tristate "Driver for Lantiq PHYs"
@@ -27,11 +25,9 @@ index 961f0b2..41a2992 100644
config FIXED_PHY
bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
depends on PHYLIB=y
-diff --git a/drivers/net/phy/Makefile b/drivers/net/phy/Makefile
-index 9645e38..e2eeee3 100644
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
-@@ -23,6 +23,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
+@@ -39,6 +39,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
obj-$(CONFIG_DP83640_PHY) += dp83640.o
obj-$(CONFIG_STE10XP) += ste10Xp.o
obj-$(CONFIG_MICREL_PHY) += micrel.o
@@ -39,9 +35,6 @@ index 9645e38..e2eeee3 100644
obj-$(CONFIG_MDIO_OCTEON) += mdio-octeon.o
obj-$(CONFIG_MICREL_KS8995MA) += spi_ks8995.o
obj-$(CONFIG_AT803X_PHY) += at803x.o
-diff --git a/drivers/net/phy/lantiq.c b/drivers/net/phy/lantiq.c
-new file mode 100644
-index 0000000..418dff0
--- /dev/null
+++ b/drivers/net/phy/lantiq.c
@@ -0,0 +1,220 @@
@@ -265,6 +258,3 @@ index 0000000..418dff0
+MODULE_DESCRIPTION("Lantiq PHY drivers");
+MODULE_AUTHOR("Daniel Schwierzeck <daniel.schwierzeck@googlemail.com>");
+MODULE_LICENSE("GPL");
---
-1.7.10.4
-