aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/profiles/110-nas.mk
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-02-15 23:53:08 +0000
committerLuka Perkov <luka@openwrt.org>2014-02-15 23:53:08 +0000
commitb24acf0794c999ef600a25fbd2485e69a823b346 (patch)
treeceea557d97b4a08faf543f696dc839b37c6ad1fd /target/linux/kirkwood/profiles/110-nas.mk
parent8cc29e4be3b5892308d39fbd14cf789f12836671 (diff)
downloadmaster-187ad058-b24acf0794c999ef600a25fbd2485e69a823b346.tar.gz
master-187ad058-b24acf0794c999ef600a25fbd2485e69a823b346.tar.bz2
master-187ad058-b24acf0794c999ef600a25fbd2485e69a823b346.zip
kirkwood: update support for iconnect
Previous patch was pushed due to false user report. While at it fix alphabetic ordering. The board is optimized for ubi(fs) and boots OpenWrt without changes to uboot environment if OpenWrt's uboot package is used. In order to flash the image run following commands in uboot shell: nand erase 0x200000 0x1fe00000 ubi part root ; ubi remove rootfs ; ubi create rootfs tftpboot 0x800000 openwrt-kirkwood-iconnect-rootfs.ubifs ; ubi write 0x800000 rootfs ${filesize} ; reset Signed-off-by: Luka Perkov <luka@openwrt.org> CC: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39591 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/kirkwood/profiles/110-nas.mk')
-rw-r--r--target/linux/kirkwood/profiles/110-nas.mk30
1 files changed, 15 insertions, 15 deletions
diff --git a/target/linux/kirkwood/profiles/110-nas.mk b/target/linux/kirkwood/profiles/110-nas.mk
index 07a9797e55..6605f69362 100644
--- a/target/linux/kirkwood/profiles/110-nas.mk
+++ b/target/linux/kirkwood/profiles/110-nas.mk
@@ -22,21 +22,6 @@ DOCKSTAR_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
$(eval $(call Profile,DOCKSTAR))
-define Profile/ICONNECT
- NAME:=Iomega Iconnect
- PACKAGES:= \
- kmod-usb2 kmod-usb-storage
-endef
-
-define Profile/ICONNECT/Description
- Package set compatible with Iomega Iconnect board.
-endef
-
-ICONNECT_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
-ICONNECT_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
-
-$(eval $(call Profile,ICONNECT))
-
define Profile/IB62X0
NAME:=RaidSonic ICY BOX IB-NAS62x0
PACKAGES:= \
@@ -53,3 +38,18 @@ IB62X0_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
IB62X0_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
$(eval $(call Profile,IB62X0))
+
+define Profile/ICONNECT
+ NAME:=Iomega Iconnect
+ PACKAGES:= \
+ kmod-usb2 kmod-usb-storage
+endef
+
+define Profile/ICONNECT/Description
+ Package set compatible with Iomega Iconnect board.
+endef
+
+ICONNECT_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+ICONNECT_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,ICONNECT))