aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx-2.6/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
commit53aef8417d5b9e00e4b74b022ed03975c732d8e9 (patch)
tree56570ca509d7826cb8163622a96ddac70562068c /target/linux/ixp4xx-2.6/image
parentbf32023e6c902f04f995d7e787a72129794a16ba (diff)
downloadmaster-187ad058-53aef8417d5b9e00e4b74b022ed03975c732d8e9.tar.gz
master-187ad058-53aef8417d5b9e00e4b74b022ed03975c732d8e9.tar.bz2
master-187ad058-53aef8417d5b9e00e4b74b022ed03975c732d8e9.zip
Add initial version of the new Image Builder
It's still a bit rough in a few places, but it seems to work for Broadcom at least - other targets untested. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6071 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ixp4xx-2.6/image')
-rw-r--r--target/linux/ixp4xx-2.6/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ixp4xx-2.6/image/Makefile b/target/linux/ixp4xx-2.6/image/Makefile
index 9359c5b11e..cbbb29b6b9 100644
--- a/target/linux/ixp4xx-2.6/image/Makefile
+++ b/target/linux/ixp4xx-2.6/image/Makefile
@@ -24,10 +24,11 @@ define Build/Clean
endef
define Image/Prepare
+ cp $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/zImage
endef
define Image/BuildKernel
- cp $(LINUX_DIR)/arch/arm/boot/zImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-zImage
+ cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-zImage
# $(shell BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh)
BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh
endef