aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx-2.6/image
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-11-28 20:14:41 +0000
committerMike Baker <mbm@openwrt.org>2006-11-28 20:14:41 +0000
commit3ba3ea17ba671bf4bd7632fffa3d37728112acd4 (patch)
treea07315dd45c6ac0f7d0e6a337cf58f7d7b09d07f /target/linux/ixp4xx-2.6/image
parent1a9e1bf731c009cdde791100b96fc4f6404d83ea (diff)
downloadmaster-187ad058-3ba3ea17ba671bf4bd7632fffa3d37728112acd4.tar.gz
master-187ad058-3ba3ea17ba671bf4bd7632fffa3d37728112acd4.tar.bz2
master-187ad058-3ba3ea17ba671bf4bd7632fffa3d37728112acd4.zip
move target/image/platform to target/linux/platform/image
platform directories are now self contained git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5669 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ixp4xx-2.6/image')
-rw-r--r--target/linux/ixp4xx-2.6/image/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/ixp4xx-2.6/image/Makefile b/target/linux/ixp4xx-2.6/image/Makefile
new file mode 100644
index 0000000000..23a0644338
--- /dev/null
+++ b/target/linux/ixp4xx-2.6/image/Makefile
@@ -0,0 +1,32 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Build/Clean
+endef
+
+define Image/Prepare
+endef
+
+define Image/BuildKernel
+ cp $(LINUX_DIR)/arch/arm/boot/zImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-zImage
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-64k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=65536 conv=sync
+endef
+
+define Image/Build/jffs2-128k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
+endef
+
+$(eval $(call BuildImage))