aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/profiles
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-09-04 14:46:06 +0000
committerJonas Gorski <jogo@openwrt.org>2015-09-04 14:46:06 +0000
commit897157d1c3224a676d72115df7d42d1cef9f5655 (patch)
treea55c2ad3d99d1d568598837d2f7d6025684668fd /target/linux/ipq806x/profiles
parent74a1d6e0e8e21ec9f503df5f21746e20aeaa0859 (diff)
downloadmaster-187ad058-897157d1c3224a676d72115df7d42d1cef9f5655.tar.gz
master-187ad058-897157d1c3224a676d72115df7d42d1cef9f5655.tar.bz2
master-187ad058-897157d1c3224a676d72115df7d42d1cef9f5655.zip
ipq806x: add support for Netgear Nighthawk X4 R7500
Add support for the Netgear Nighthawk X4 R7500 and build appropariate sysupgrade and factory images. Known issues: * 5 GHz wifi not working - there is no quantenna driver * One of the USB ports is not working Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46796 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ipq806x/profiles')
-rw-r--r--target/linux/ipq806x/profiles/netgear.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ipq806x/profiles/netgear.mk b/target/linux/ipq806x/profiles/netgear.mk
new file mode 100644
index 0000000000..3402f45853
--- /dev/null
+++ b/target/linux/ipq806x/profiles/netgear.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (c) 2014 The Linux Foundation. All rights reserved.
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/R7500
+ NAME:=Netgear Nighthawk X4 R7500
+ PACKAGES:= \
+ kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
+ kmod-usb3 kmod-usb-dwc3-qcom kmod-usb-phy-qcom-dwc3 \
+ kmod-ath10k wpad-mini
+endef
+
+define Profile/R7500/Description
+ Package set for the Netgear Nighthawk X4 R7500.
+endef
+$(eval $(call Profile,R7500))