aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/profiles/netgear.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-01-19 10:16:36 +0000
committerJohn Crispin <blogic@openwrt.org>2016-01-19 10:16:36 +0000
commitd1e706e8b7dc148eba9d4f0e9a4af24930f1d083 (patch)
treea4a3723808695c1f0c2182204861d60fbd7c4b95 /target/linux/ipq806x/profiles/netgear.mk
parenta988dbf082e3bfef71ff136d81b3311929ffe97f (diff)
downloadmaster-187ad058-d1e706e8b7dc148eba9d4f0e9a4af24930f1d083.tar.gz
master-187ad058-d1e706e8b7dc148eba9d4f0e9a4af24930f1d083.tar.bz2
master-187ad058-d1e706e8b7dc148eba9d4f0e9a4af24930f1d083.zip
ipq806x: Add support for Netgear D7800
Signed-off-by: Tathagata Das <tathagata@alumnux.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48360 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ipq806x/profiles/netgear.mk')
-rw-r--r--target/linux/ipq806x/profiles/netgear.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ipq806x/profiles/netgear.mk b/target/linux/ipq806x/profiles/netgear.mk
index 3402f45853..25258cdca3 100644
--- a/target/linux/ipq806x/profiles/netgear.mk
+++ b/target/linux/ipq806x/profiles/netgear.mk
@@ -6,6 +6,18 @@
# See /LICENSE for more information.
#
+define Profile/D7800
+ NAME:=Netgear Nighthawk X4 D7800
+ PACKAGES:= \
+ kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
+ kmod-usb3 kmod-usb-dwc3-qcom kmod-usb-phy-qcom-dwc3 \
+ kmod-ath10k wpad-mini ath10k-firmware-qca99x0
+endef
+
+define Profile/D7800/Description
+ Package set for the Netgear Nighthawk X4 D7800.
+endef
+
define Profile/R7500
NAME:=Netgear Nighthawk X4 R7500
PACKAGES:= \
@@ -17,4 +29,5 @@ endef
define Profile/R7500/Description
Package set for the Netgear Nighthawk X4 R7500.
endef
+$(eval $(call Profile,D7800))
$(eval $(call Profile,R7500))