aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ipq806x/patches-4.4/302-mtd-qcom-smem-rename-rootfs-ubi.patch
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2016-06-23 18:51:35 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-23 18:51:35 +0200
commit880fddf86bfb0bb2452a33da6622d9d29c71d9bd (patch)
tree2e1945fd7539b4a3c614297d5fcf45ecde4a794a /target/linux/ipq806x/patches-4.4/302-mtd-qcom-smem-rename-rootfs-ubi.patch
parent993ba6b10921e6842d3cd09f9ef2f86cfddfc46a (diff)
downloadmaster-187ad058-880fddf86bfb0bb2452a33da6622d9d29c71d9bd.tar.gz
master-187ad058-880fddf86bfb0bb2452a33da6622d9d29c71d9bd.tar.bz2
master-187ad058-880fddf86bfb0bb2452a33da6622d9d29c71d9bd.zip
ipq806x: update bomb
ipq806x: Add support for linux-4.4 ipq806x: Add Archer C2600 to image/Makefile ipq806x/base-files: Add Archer C2600 LEDs and board ipq806x/base-files: Add support for Archer C2600 ipq806x/base-files: extract ath10k caldata ipq806x/dts: Add Archer C2600 DTS ipq806x: enable PM support ipq806x: add a default profile ipq806x: add diag.sh script ipq806x: qcom rpm fix support for smb208 mtd: add linksys_bootcount for ipq806x uboot-envtools: add ipq806x support Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Diffstat (limited to 'target/linux/ipq806x/patches-4.4/302-mtd-qcom-smem-rename-rootfs-ubi.patch')
-rw-r--r--target/linux/ipq806x/patches-4.4/302-mtd-qcom-smem-rename-rootfs-ubi.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ipq806x/patches-4.4/302-mtd-qcom-smem-rename-rootfs-ubi.patch b/target/linux/ipq806x/patches-4.4/302-mtd-qcom-smem-rename-rootfs-ubi.patch
new file mode 100644
index 0000000000..8890a91731
--- /dev/null
+++ b/target/linux/ipq806x/patches-4.4/302-mtd-qcom-smem-rename-rootfs-ubi.patch
@@ -0,0 +1,13 @@
+--- a/drivers/mtd/qcom_smem_part.c
++++ b/drivers/mtd/qcom_smem_part.c
+@@ -189,6 +189,10 @@ static int parse_qcom_smem_partitions(st
+ m_part->size = le32_to_cpu(s_part->size) * (*smem_blksz);
+ m_part->offset = le32_to_cpu(s_part->start) * (*smem_blksz);
+
++ /* "rootfs" conflicts with OpenWrt auto mounting */
++ if (mtd_type_is_nand(master) && !strcmp(m_part->name, "rootfs"))
++ m_part->name = "ubi";
++
+ /*
+ * The last SMEM partition may have its size marked as
+ * something like 0xffffffff, which means "until the end of the