aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/iop32x-2.6/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-03-11 19:49:50 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-03-11 19:49:50 +0000
commitaec06de3db354b1e61bc0d80dc189e2e4745011c (patch)
treebbe0ba5a36b5eac782809bd5b644f4aacd90d8b4 /target/linux/iop32x-2.6/image
parentd25369bfb5342422520f4ea5b3aff38c8215fd0b (diff)
downloadmaster-187ad058-aec06de3db354b1e61bc0d80dc189e2e4745011c.tar.gz
master-187ad058-aec06de3db354b1e61bc0d80dc189e2e4745011c.tar.bz2
master-187ad058-aec06de3db354b1e61bc0d80dc189e2e4745011c.zip
add preliminary IOP32x support, mark it broken for now
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6557 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/iop32x-2.6/image')
-rw-r--r--target/linux/iop32x-2.6/image/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/target/linux/iop32x-2.6/image/Makefile b/target/linux/iop32x-2.6/image/Makefile
new file mode 100644
index 0000000000..d1fbd3f3ea
--- /dev/null
+++ b/target/linux/iop32x-2.6/image/Makefile
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/zImage
+endef
+
+define Image/BuildKernel
+ cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-zImage
+#
+# XXX - FIXME
+#
+# BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-64k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=65536 conv=sync
+endef
+
+define Image/Build/jffs2-128k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
+ $(call Image/Build/slug,$(1))
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
+ $(call Image/Build/slug,$(1))
+endef
+
+$(eval $(call BuildImage))