aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/iop32x-2.6/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-03-11 19:49:50 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-03-11 19:49:50 +0000
commitaec06de3db354b1e61bc0d80dc189e2e4745011c (patch)
treebbe0ba5a36b5eac782809bd5b644f4aacd90d8b4 /target/linux/iop32x-2.6/Makefile
parentd25369bfb5342422520f4ea5b3aff38c8215fd0b (diff)
downloadmaster-187ad058-aec06de3db354b1e61bc0d80dc189e2e4745011c.tar.gz
master-187ad058-aec06de3db354b1e61bc0d80dc189e2e4745011c.tar.bz2
master-187ad058-aec06de3db354b1e61bc0d80dc189e2e4745011c.zip
add preliminary IOP32x support, mark it broken for now
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6557 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/iop32x-2.6/Makefile')
-rw-r--r--target/linux/iop32x-2.6/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/iop32x-2.6/Makefile b/target/linux/iop32x-2.6/Makefile
new file mode 100644
index 0000000000..58a1f27467
--- /dev/null
+++ b/target/linux/iop32x-2.6/Makefile
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=iop32x
+BOARDNAME:=Intel XScale IOP32x
+FEATURES:=squashfs jffs2 broken
+
+define Target/Description
+endef
+
+include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
+$(eval $(call BuildKernel))