aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/imx6
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-07-10 22:02:24 +0000
committerJohn Crispin <blogic@openwrt.org>2014-07-10 22:02:24 +0000
commitf97b4208d591f7488463958ee9100c66e270ef4f (patch)
treee3ab1c4543319cdf09fe81a4055d8ef20acdc042 /target/linux/imx6
parent9cb74f0caaec65f72db2d36d4986d9912f6fe63b (diff)
downloadmaster-187ad058-f97b4208d591f7488463958ee9100c66e270ef4f.tar.gz
master-187ad058-f97b4208d591f7488463958ee9100c66e270ef4f.tar.bz2
master-187ad058-f97b4208d591f7488463958ee9100c66e270ef4f.zip
imx6: put kernel and dtb into rootfs by default
this will make the rc1 images boot with the default config. Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41578 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/imx6')
-rw-r--r--target/linux/imx6/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 1c68cb0e40..b07dd4fc8c 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -42,9 +42,9 @@ endef
define Image/InstallKernel/Template
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL)$(CONFIG_TARGET_imx6_VENTANA),)
$(INSTALL_DIR) $(TARGET_DIR)/boot
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE)$(CONFIG_TARGET_imx6_VENTANA),)
$(CP) $(BIN_DIR)/$(IMG_PREFIX)-uImage $(TARGET_DIR)/boot/
ln -sf $(IMG_PREFIX)-uImage $(TARGET_DIR)/boot/uImage
endif
@@ -59,7 +59,7 @@ define Image/InstallKernel/Template
endif
endif
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB)$(CONFIG_TARGET_imx6_VENTANA),)
$(INSTALL_DIR) $(TARGET_DIR)/boot
$(foreach dts,$(shell echo $(1)), \
$(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(dts).dtb $(TARGET_DIR)/boot/ ; \