aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/image/x86
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-10-23 18:47:07 +0000
committerNicolas Thill <nico@openwrt.org>2005-10-23 18:47:07 +0000
commit4e6c8d29289498615d76b98416dffbed17dc1c46 (patch)
treec45f473b69eb028554f983c82bf247220fd9dcef /target/linux/image/x86
parent69586bf8d1c231d1ef57e0dfa3f43a1d6481bc90 (diff)
downloadmaster-187ad058-4e6c8d29289498615d76b98416dffbed17dc1c46.tar.gz
master-187ad058-4e6c8d29289498615d76b98416dffbed17dc1c46.tar.bz2
master-187ad058-4e6c8d29289498615d76b98416dffbed17dc1c46.zip
rename soekris port to x86
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2285 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/image/x86')
-rw-r--r--target/linux/image/x86/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/target/linux/image/x86/Makefile b/target/linux/image/x86/Makefile
new file mode 100644
index 0000000000..37600c91db
--- /dev/null
+++ b/target/linux/image/x86/Makefile
@@ -0,0 +1,36 @@
+include $(TOPDIR)/rules.mk
+
+KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
+
+
+ifeq ($(FS),jffs2-8MB)
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img: $(KDIR)/root.$(FS)
+ cp $^ $@
+
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).img
+
+endif
+
+
+ifeq ($(FS),tgz)
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz: $(KDIR)/root.tar.gz
+ cp $^ $@
+
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tar.gz
+
+endif
+
+
+$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz: $(KDIR)/bzImage
+ cp $^ $@
+
+
+clean:
+prepare:
+compile:
+install: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
+install-ib:
+ mkdir -p $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)
+ cp -fpR $(KDIR)/bzImage $(IB_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD)/