aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ifxmips/danube/profiles
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2010-04-10 20:11:28 +0000
committerJohn Crispin <blogic@openwrt.org>2010-04-10 20:11:28 +0000
commit43f0e5766403d5d48f4540089d446b2d205d5b85 (patch)
treed38795257e7a4e8fcbdda67339364f9c559ccaea /target/linux/ifxmips/danube/profiles
parentb11c2280a3f663bccf248e31f78b912c6ca30378 (diff)
downloadmaster-187ad058-43f0e5766403d5d48f4540089d446b2d205d5b85.tar.gz
master-187ad058-43f0e5766403d5d48f4540089d446b2d205d5b85.tar.bz2
master-187ad058-43f0e5766403d5d48f4540089d446b2d205d5b85.zip
[ifxmips] adss 2.6.33 kernel patches, not defult yet as linux-atm breaks on 2.6.33
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20789 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ifxmips/danube/profiles')
-rw-r--r--target/linux/ifxmips/danube/profiles/000-None.mk17
-rw-r--r--target/linux/ifxmips/danube/profiles/100-Atheros.mk17
-rw-r--r--target/linux/ifxmips/danube/profiles/200-Ralink.mk17
3 files changed, 51 insertions, 0 deletions
diff --git a/target/linux/ifxmips/danube/profiles/000-None.mk b/target/linux/ifxmips/danube/profiles/000-None.mk
new file mode 100644
index 0000000000..95b04eed9d
--- /dev/null
+++ b/target/linux/ifxmips/danube/profiles/000-None.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/None
+ NAME:=Generic, No WiFi
+ PACKAGES:=-wpad-mini
+endef
+
+define Profile/None/Description
+ Package set without WiFi support
+endef
+$(eval $(call Profile,None))
+
diff --git a/target/linux/ifxmips/danube/profiles/100-Atheros.mk b/target/linux/ifxmips/danube/profiles/100-Atheros.mk
new file mode 100644
index 0000000000..71804b294f
--- /dev/null
+++ b/target/linux/ifxmips/danube/profiles/100-Atheros.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+ NAME:=Atheros WiFi (default)
+ PACKAGES:=kmod-madwifi
+endef
+
+define Profile/Atheros/Description
+ Package set compatible with hardware using Atheros WiFi cards
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/ifxmips/danube/profiles/200-Ralink.mk b/target/linux/ifxmips/danube/profiles/200-Ralink.mk
new file mode 100644
index 0000000000..dd9716ab59
--- /dev/null
+++ b/target/linux/ifxmips/danube/profiles/200-Ralink.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Ralink
+ NAME:=Ralink RT61 Wifi (ARV452)
+ PACKAGES:=kmod-rt61-pci
+endef
+
+define Profile/Ralink/Description
+ Package set compatible with hardware using Ralink WiFi cards
+endef
+$(eval $(call Profile,Ralink))
+