aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/goldfish/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-06-14 20:42:33 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-06-14 20:42:33 +0000
commit2d5f80251c73e1e44c8fdd047ef49dbe051d65aa (patch)
tree74597f2d6eef2e7a6d6338c978b8910f9f947151 /target/linux/goldfish/image/Makefile
parent157a4ab64660aaca2dd51fa4f82239d3738a1dff (diff)
downloadmaster-187ad058-2d5f80251c73e1e44c8fdd047ef49dbe051d65aa.tar.gz
master-187ad058-2d5f80251c73e1e44c8fdd047ef49dbe051d65aa.tar.bz2
master-187ad058-2d5f80251c73e1e44c8fdd047ef49dbe051d65aa.zip
add the 'goldfish' target, useful for experimenting with virtual phone hardware (includes the emulator)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16459 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/goldfish/image/Makefile')
-rw-r--r--target/linux/goldfish/image/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/target/linux/goldfish/image/Makefile b/target/linux/goldfish/image/Makefile
new file mode 100644
index 0000000000..bf871fb2ae
--- /dev/null
+++ b/target/linux/goldfish/image/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+JFFS2_BLOCKSIZE=124k
+JFFS2OPTS += -n -s 2048
+
+_PREFIX=openwrt-goldfish-
+
+define Image/BuildKernel
+ $(TARGET_CROSS)objcopy -O binary -R .note -R .comment -S \
+ $(LINUX_DIR)/arch/arm/boot/compressed/vmlinux $(BIN_DIR)/$(_PREFIX)kernel.bin
+ $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS), \
+ $(CP) $(LINUX_DIR)/usr/initramfs_data.cpio.gz, \
+ gzip -c < $(LINUX_DIR)/usr/initramfs_data.cpio > \
+ ) $(BIN_DIR)/$(_PREFIX)ramdisk.bin
+ $(CP) ./run-emulator.sh $(BIN_DIR)/
+endef
+
+define Image/Build/jffs2-124k
+ $(CP) ./ubinize.cfg $(KDIR)/
+ (cd $(KDIR); \
+ ubinize \
+ -o $(BIN_DIR)/$(_PREFIX)$(1).img \
+ -p 128KiB -m 2KiB -s 2KiB ubinize.cfg; \
+ )
+ nand_ecc \
+ $(BIN_DIR)/$(_PREFIX)$(1).img \
+ $(BIN_DIR)/$(_PREFIX)system.bin
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+
+$(eval $(call BuildImage))