aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.4
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-02-26 09:49:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-02-26 09:49:32 +0000
commit0daed9bb05d2ef27bb11818e4bc2b6beea653b69 (patch)
tree4abdb2e1baa438c67b49f0cbf9035d178331cefe /target/linux/generic/patches-4.4
parentc0e6a07849bcfd505dcc1dffcd95b2c3ba9ada1e (diff)
downloadmaster-187ad058-0daed9bb05d2ef27bb11818e4bc2b6beea653b69.tar.gz
master-187ad058-0daed9bb05d2ef27bb11818e4bc2b6beea653b69.tar.bz2
master-187ad058-0daed9bb05d2ef27bb11818e4bc2b6beea653b69.zip
kernel: disable MIPS VDSO by default until the cache issues have been resolved
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48802 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-4.4')
-rw-r--r--target/linux/generic/patches-4.4/206-mips-disable-vdso.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.4/206-mips-disable-vdso.patch b/target/linux/generic/patches-4.4/206-mips-disable-vdso.patch
new file mode 100644
index 0000000000..9b1346db81
--- /dev/null
+++ b/target/linux/generic/patches-4.4/206-mips-disable-vdso.patch
@@ -0,0 +1,21 @@
+Disable MIPS VDSO until the cache issues have been sorted out.
+
+Signed-off-by: Felix Fietkau <nbd@openwrt.org>
+
+--- a/arch/mips/vdso/Makefile
++++ b/arch/mips/vdso/Makefile
+@@ -26,11 +26,11 @@ aflags-vdso := $(ccflags-vdso) \
+ # the comments on that file.
+ #
+ ifndef CONFIG_CPU_MIPSR6
+- ifeq ($(call ld-ifversion, -lt, 22500000, y),y)
+- $(warning MIPS VDSO requires binutils >= 2.25)
++# ifeq ($(call ld-ifversion, -lt, 22500000, y),y)
++# $(warning MIPS VDSO requires binutils >= 2.25)
+ obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
+ ccflags-vdso += -DDISABLE_MIPS_VDSO
+- endif
++# endif
+ endif
+
+ # VDSO linker flags.