aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.3/940-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2015-10-11 19:08:08 +0000
committerHauke Mehrtens <hauke@openwrt.org>2015-10-11 19:08:08 +0000
commitebc8ef9e87b724526a60e1670834fff4d3bc4698 (patch)
tree190d5518cb8fca114ade113bd2689f1b54852d08 /target/linux/generic/patches-4.3/940-ocf_kbuild_integration.patch
parent0ab09e313739ebe5a2d9c3c35354422149760383 (diff)
downloadmaster-187ad058-ebc8ef9e87b724526a60e1670834fff4d3bc4698.tar.gz
master-187ad058-ebc8ef9e87b724526a60e1670834fff4d3bc4698.tar.bz2
master-187ad058-ebc8ef9e87b724526a60e1670834fff4d3bc4698.zip
kernel: generic: add kernel 4.3
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47182 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-4.3/940-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-4.3/940-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.3/940-ocf_kbuild_integration.patch b/target/linux/generic/patches-4.3/940-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..68f0a847d2
--- /dev/null
+++ b/target/linux/generic/patches-4.3/940-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -1645,3 +1645,6 @@ source crypto/asymmetric_keys/Kconfig
+ source certs/Kconfig
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -119,6 +119,8 @@ obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) +
+ obj-$(CONFIG_CRYPTO_USER_API_RNG) += algif_rng.o
+ obj-$(CONFIG_CRYPTO_USER_API_AEAD) += algif_aead.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #