aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-4.1/011-perf-tools-Fix-makefile-generation-under-dash.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-14 01:00:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-14 01:00:38 +0000
commit8a8a936eabef433194c8c148370d59fe9f8501fd (patch)
tree4033638d0a284d2c143b447bbb429d6544a2ad2a /target/linux/generic/patches-4.1/011-perf-tools-Fix-makefile-generation-under-dash.patch
parentfb662feccd137435fda153ce762aa48c815fb26b (diff)
downloadmaster-187ad058-8a8a936eabef433194c8c148370d59fe9f8501fd.tar.gz
master-187ad058-8a8a936eabef433194c8c148370d59fe9f8501fd.tar.bz2
master-187ad058-8a8a936eabef433194c8c148370d59fe9f8501fd.zip
kernel: backport perf build fixes to 4.1
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48231 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-4.1/011-perf-tools-Fix-makefile-generation-under-dash.patch')
-rw-r--r--target/linux/generic/patches-4.1/011-perf-tools-Fix-makefile-generation-under-dash.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/generic/patches-4.1/011-perf-tools-Fix-makefile-generation-under-dash.patch b/target/linux/generic/patches-4.1/011-perf-tools-Fix-makefile-generation-under-dash.patch
new file mode 100644
index 0000000000..45ea1a04f2
--- /dev/null
+++ b/target/linux/generic/patches-4.1/011-perf-tools-Fix-makefile-generation-under-dash.patch
@@ -0,0 +1,27 @@
+From: Sergei Trofimovich <siarheit@google.com>
+Date: Sun, 19 Jul 2015 10:30:05 +0100
+Subject: [PATCH] perf tools: Fix makefile generation under dash
+
+Under dash 'echo -n' yields '-n' to stdout. Use printf "" instead.
+
+Signed-off-by: Sergei Trofimovich <siarheit@google.com>
+Acked-by: Ingo Molnar <mingo@kernel.org>
+Acked-by: Jiri Olsa <jolsa@kernel.org>
+Cc: Adrian Hunter <adrian.hunter@intel.com>
+Cc: Namhyung Kim <namhyung@kernel.org>
+Cc: Peter Zijlstra <a.p.zijlstra@chello.nl>
+Link: http://lkml.kernel.org/r/1437298205-29305-1-git-send-email-siarheit@google.com
+Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
+---
+
+--- a/tools/perf/config/Makefile
++++ b/tools/perf/config/Makefile
+@@ -11,7 +11,7 @@ ifneq ($(obj-perf),)
+ obj-perf := $(abspath $(obj-perf))/
+ endif
+
+-$(shell echo -n > $(OUTPUT).config-detected)
++$(shell printf "" > $(OUTPUT).config-detected)
+ detected = $(shell echo "$(1)=y" >> $(OUTPUT).config-detected)
+ detected_var = $(shell echo "$(1)=$($(1))" >> $(OUTPUT).config-detected)
+