aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.8/865-gpiopwm.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-01-08 22:19:31 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-01-08 22:19:31 +0000
commitce99d2278c894e83d931741f6652904908cc382b (patch)
treeeca211bce457b867f3e5fd2acded634db17c76cf /target/linux/generic/patches-3.8/865-gpiopwm.patch
parent44cf7625b0ff51ffea83b8142e69002aee6fc4eb (diff)
downloadmaster-187ad058-ce99d2278c894e83d931741f6652904908cc382b.tar.gz
master-187ad058-ce99d2278c894e83d931741f6652904908cc382b.tar.bz2
master-187ad058-ce99d2278c894e83d931741f6652904908cc382b.zip
kernel: add support for 3.8-rc2
Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35055 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.8/865-gpiopwm.patch')
-rw-r--r--target/linux/generic/patches-3.8/865-gpiopwm.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.8/865-gpiopwm.patch b/target/linux/generic/patches-3.8/865-gpiopwm.patch
new file mode 100644
index 0000000000..f899d1a63a
--- /dev/null
+++ b/target/linux/generic/patches-3.8/865-gpiopwm.patch
@@ -0,0 +1,21 @@
+--- a/drivers/Kconfig
++++ b/drivers/Kconfig
+@@ -62,6 +62,8 @@ source "drivers/pinctrl/Kconfig"
+
+ source "drivers/gpio/Kconfig"
+
++source "drivers/pwm/Kconfig"
++
+ source "drivers/w1/Kconfig"
+
+ source "drivers/power/Kconfig"
+--- a/drivers/Makefile
++++ b/drivers/Makefile
+@@ -13,6 +13,7 @@ obj-y += pinctrl/
+ obj-y += gpio/
+ obj-y += pwm/
+ obj-$(CONFIG_PCI) += pci/
++obj-$(CONFIG_GENERIC_PWM) += pwm/
+ obj-$(CONFIG_PARISC) += parisc/
+ obj-$(CONFIG_RAPIDIO) += rapidio/
+ obj-y += video/