aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.7/729-phy-tantos.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2012-11-18 18:52:38 +0000
committerImre Kaloz <kaloz@openwrt.org>2012-11-18 18:52:38 +0000
commit43d2eb64ccb3a223ba2244faee1280aaa6f68d11 (patch)
tree86525769ccc1e76c33de9d10b51d14bdc0e1c8f7 /target/linux/generic/patches-3.7/729-phy-tantos.patch
parent2b0cba675561342a1a538bad8a7df10cf855323e (diff)
downloadmaster-187ad058-43d2eb64ccb3a223ba2244faee1280aaa6f68d11.tar.gz
master-187ad058-43d2eb64ccb3a223ba2244faee1280aaa6f68d11.tar.bz2
master-187ad058-43d2eb64ccb3a223ba2244faee1280aaa6f68d11.zip
[generic]: add 3.7-rc6 support (patch 820 still has to be fixed)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34247 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.7/729-phy-tantos.patch')
-rw-r--r--target/linux/generic/patches-3.7/729-phy-tantos.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.7/729-phy-tantos.patch b/target/linux/generic/patches-3.7/729-phy-tantos.patch
new file mode 100644
index 0000000000..bc8be2b0dc
--- /dev/null
+++ b/target/linux/generic/patches-3.7/729-phy-tantos.patch
@@ -0,0 +1,21 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -257,3 +257,8 @@ endif # PHYLIB
+ config MICREL_KS8995MA
+ tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
+ depends on SPI
++
++config PSB6970_PHY
++ tristate "Lantiq XWAY Tantos (PSB6970) Ethernet switch"
++ select SWCONFIG
++ select ETHERNET_PACKET_MANGLE
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -30,6 +30,7 @@ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+ obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_MICREL_PHY) += micrel.o
++obj-$(CONFIG_PSB6970_PHY) += psb6970.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o