aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.2/723-phy_ip175c.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2012-01-13 14:55:07 +0000
committerJonas Gorski <jogo@openwrt.org>2012-01-13 14:55:07 +0000
commitb49e97601bba8ba4075085b69e00952373e18af2 (patch)
tree322fc313a19bc903c788a7acf9b6fabef06b04e5 /target/linux/generic/patches-3.2/723-phy_ip175c.patch
parentef7ec19360f373ead4bffc66c10fd70ec6c1aa78 (diff)
downloadmaster-187ad058-b49e97601bba8ba4075085b69e00952373e18af2.tar.gz
master-187ad058-b49e97601bba8ba4075085b69e00952373e18af2.tar.bz2
master-187ad058-b49e97601bba8ba4075085b69e00952373e18af2.zip
kernel: add support for linux 3.2.1
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29730 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.2/723-phy_ip175c.patch')
-rw-r--r--target/linux/generic/patches-3.2/723-phy_ip175c.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.2/723-phy_ip175c.patch b/target/linux/generic/patches-3.2/723-phy_ip175c.patch
new file mode 100644
index 0000000000..0ac339e9a2
--- /dev/null
+++ b/target/linux/generic/patches-3.2/723-phy_ip175c.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -112,6 +112,10 @@ config ADM6996_PHY
+ config MVSWITCH_PHY
+ tristate "Driver for Marvell 88E6060 switches"
+
++config IP17XX_PHY
++ tristate "Driver for IC+ IP17xx switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -16,6 +16,7 @@ obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
++obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o