aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.19/430-mtd-add-myloader-partition-parser.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-03-26 09:42:59 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-03-26 09:42:59 +0000
commitb22936646d66f2a36a70ddeb9c66a44f07b8c4ac (patch)
tree485bf7cec86903e0ab0d5cbf0daa13e36e3ab5f1 /target/linux/generic/patches-3.19/430-mtd-add-myloader-partition-parser.patch
parent90cd852f2508f82c8e02c5ee6b97ba7bf1823c55 (diff)
downloadmaster-187ad058-b22936646d66f2a36a70ddeb9c66a44f07b8c4ac.tar.gz
master-187ad058-b22936646d66f2a36a70ddeb9c66a44f07b8c4ac.tar.bz2
master-187ad058-b22936646d66f2a36a70ddeb9c66a44f07b8c4ac.zip
drop 3.19 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45002 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.19/430-mtd-add-myloader-partition-parser.patch')
-rw-r--r--target/linux/generic/patches-3.19/430-mtd-add-myloader-partition-parser.patch35
1 files changed, 0 insertions, 35 deletions
diff --git a/target/linux/generic/patches-3.19/430-mtd-add-myloader-partition-parser.patch b/target/linux/generic/patches-3.19/430-mtd-add-myloader-partition-parser.patch
deleted file mode 100644
index 3cb5fb721a..0000000000
--- a/target/linux/generic/patches-3.19/430-mtd-add-myloader-partition-parser.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- a/drivers/mtd/Kconfig
-+++ b/drivers/mtd/Kconfig
-@@ -184,6 +184,22 @@ config MTD_BCM47XX_PARTS
- This provides partitions parser for devices based on BCM47xx
- boards.
-
-+config MTD_MYLOADER_PARTS
-+ tristate "MyLoader partition parsing"
-+ depends on ADM5120 || ATH25 || ATHEROS_AR71XX || ATH79
-+ ---help---
-+ MyLoader is a bootloader which allows the user to define partitions
-+ in flash devices, by putting a table in the second erase block
-+ on the device, similar to a partition table. This table gives the
-+ offsets and lengths of the user defined partitions.
-+
-+ If you need code which can detect and parse these tables, and
-+ register MTD 'partitions' corresponding to each image detected,
-+ enable this option.
-+
-+ You will still need the parsing functions to be called by the driver
-+ for your particular device. It won't happen automatically.
-+
- comment "User Modules And Translation Layers"
-
- #
---- a/drivers/mtd/Makefile
-+++ b/drivers/mtd/Makefile
-@@ -15,6 +15,7 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
- obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
- obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
- obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
-+obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
-
- # 'Users' - code which presents functionality to userspace.
- obj-$(CONFIG_MTD_BLKDEVS) += mtd_blkdevs.o