aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.18
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-12-08 10:04:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-12-08 10:04:39 +0000
commite760d60fa463b1c5520487d0e079ff05bbda95d1 (patch)
treeed719f2ea1c262210c72e38e21e0862e0db93cb3 /target/linux/generic/patches-3.18
parent31a1718d09ce8568da371fecb8f4cffa53a373a8 (diff)
downloadmaster-187ad058-e760d60fa463b1c5520487d0e079ff05bbda95d1.tar.gz
master-187ad058-e760d60fa463b1c5520487d0e079ff05bbda95d1.tar.bz2
master-187ad058-e760d60fa463b1c5520487d0e079ff05bbda95d1.zip
kernel: fix x86 objdump invocation on 3.14 and 3.18
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43557 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.18')
-rw-r--r--target/linux/generic/patches-3.18/270-x86_objdump_command.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.18/270-x86_objdump_command.patch b/target/linux/generic/patches-3.18/270-x86_objdump_command.patch
new file mode 100644
index 0000000000..7d4170ebee
--- /dev/null
+++ b/target/linux/generic/patches-3.18/270-x86_objdump_command.patch
@@ -0,0 +1,11 @@
+--- a/arch/x86/boot/compressed/Makefile
++++ b/arch/x86/boot/compressed/Makefile
+@@ -76,7 +76,7 @@ suffix-$(CONFIG_KERNEL_XZ) := xz
+ suffix-$(CONFIG_KERNEL_LZO) := lzo
+ suffix-$(CONFIG_KERNEL_LZ4) := lz4
+
+-RUN_SIZE = $(shell objdump -h vmlinux | \
++RUN_SIZE = $(shell $(OBJDUMP) -h vmlinux | \
+ perl $(srctree)/arch/x86/tools/calc_run_size.pl)
+ quiet_cmd_mkpiggy = MKPIGGY $@
+ cmd_mkpiggy = $(obj)/mkpiggy $< $(RUN_SIZE) > $@ || ( rm -f $@ ; false )