aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.14
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-12-01 21:30:35 +0000
committerJohn Crispin <blogic@openwrt.org>2014-12-01 21:30:35 +0000
commit92a10265c427bdffe0b7da2f50395fe01a0c43b6 (patch)
tree30d9623195ad1b7cd8ce28917b761ba3edce9d03 /target/linux/generic/patches-3.14
parent24f15f772e5e423443f35547335acffd7c37324c (diff)
downloadmaster-187ad058-92a10265c427bdffe0b7da2f50395fe01a0c43b6.tar.gz
master-187ad058-92a10265c427bdffe0b7da2f50395fe01a0c43b6.tar.bz2
master-187ad058-92a10265c427bdffe0b7da2f50395fe01a0c43b6.zip
kernel: add driver for Marvell 88E6171 switch
This is a swconfig driver for the Marvell 88E6171 switch, which is a 7-port GigE switch with two CPU ports and 64 802.1q VLANs. Signed-off-by: Claudio Leite <leitec@staticky.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43486 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.14')
-rw-r--r--target/linux/generic/patches-3.14/733-phy_mvsw6171.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.14/733-phy_mvsw6171.patch b/target/linux/generic/patches-3.14/733-phy_mvsw6171.patch
new file mode 100644
index 0000000000..991828da32
--- /dev/null
+++ b/target/linux/generic/patches-3.14/733-phy_mvsw6171.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -131,6 +131,10 @@ config MVSWITCH_PHY
+ tristate "Driver for Marvell 88E6060 switches"
+ select ETHERNET_PACKET_MANGLE
+
++config MVSW6171_PHY
++ tristate "Driver for Marvell 88E6171 switches"
++ select SWCONFIG
++
+ config IP17XX_PHY
+ tristate "Driver for IC+ IP17xx switches"
+ select SWCONFIG
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -19,6 +19,7 @@ obj-$(CONFIG_BCM87XX_PHY) += bcm87xx.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
++obj-$(CONFIG_MVSW6171_PHY) += mvsw6171.o
+ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o