aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.10/832-ledtrig_usbdev.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-05-19 18:36:15 +0000
committerJonas Gorski <jogo@openwrt.org>2013-05-19 18:36:15 +0000
commit3c5635a3aa3dd00eb47cf0191588ed64f6d10f29 (patch)
tree6b6bd393ef7dac1fdb3f9503f6bfc07e09b2ad25 /target/linux/generic/patches-3.10/832-ledtrig_usbdev.patch
parent8ef2514fb69dce5191f3e967a68663d9baa5f6d0 (diff)
downloadmaster-187ad058-3c5635a3aa3dd00eb47cf0191588ed64f6d10f29.tar.gz
master-187ad058-3c5635a3aa3dd00eb47cf0191588ed64f6d10f29.tar.bz2
master-187ad058-3c5635a3aa3dd00eb47cf0191588ed64f6d10f29.zip
kernel: generic: add 3.10-rc1 support
Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36663 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.10/832-ledtrig_usbdev.patch')
-rw-r--r--target/linux/generic/patches-3.10/832-ledtrig_usbdev.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.10/832-ledtrig_usbdev.patch b/target/linux/generic/patches-3.10/832-ledtrig_usbdev.patch
new file mode 100644
index 0000000000..27149c6d9a
--- /dev/null
+++ b/target/linux/generic/patches-3.10/832-ledtrig_usbdev.patch
@@ -0,0 +1,31 @@
+--- a/drivers/leds/trigger/Kconfig
++++ b/drivers/leds/trigger/Kconfig
+@@ -119,4 +119,11 @@ config LEDS_TRIGGER_NETDEV
+ This allows LEDs to be controlled by network device activity.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_USBDEV
++ tristate "LED USB device Trigger"
++ depends on USB && LEDS_TRIGGERS
++ help
++ This allows LEDs to be controlled by the presence/activity of
++ an USB device. If unsure, say N.
++
+ endif # LEDS_TRIGGERS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -61,3 +61,4 @@ obj-$(CONFIG_LEDS_DAC124S085) += leds-d
+ obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
++obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
+--- a/drivers/leds/ledtrig-usbdev.c
++++ b/drivers/leds/ledtrig-usbdev.c
+@@ -24,7 +24,6 @@
+ #include <linux/list.h>
+ #include <linux/spinlock.h>
+ #include <linux/device.h>
+-#include <linux/sysdev.h>
+ #include <linux/timer.h>
+ #include <linux/ctype.h>
+ #include <linux/slab.h>