aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.0/830-ledtrig_morse.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2011-06-15 21:31:01 +0000
committerHauke Mehrtens <hauke@openwrt.org>2011-06-15 21:31:01 +0000
commita3c7fb6d3956d979f8fc3b770b73fe5c3cd0f741 (patch)
treeddcbfa29bdb1ce96cc700e7ed428a098053ecf8f /target/linux/generic/patches-3.0/830-ledtrig_morse.patch
parent2e55411ec7cfe7a8198b9c2a2ba771600ec882a9 (diff)
downloadmaster-187ad058-a3c7fb6d3956d979f8fc3b770b73fe5c3cd0f741.tar.gz
master-187ad058-a3c7fb6d3956d979f8fc3b770b73fe5c3cd0f741.tar.bz2
master-187ad058-a3c7fb6d3956d979f8fc3b770b73fe5c3cd0f741.zip
linux/generic: Add support for 3.0-rc3
Also make linux identify itself properly as 3.0, not 3.0.0. Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27191 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.0/830-ledtrig_morse.patch')
-rw-r--r--target/linux/generic/patches-3.0/830-ledtrig_morse.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.0/830-ledtrig_morse.patch b/target/linux/generic/patches-3.0/830-ledtrig_morse.patch
new file mode 100644
index 0000000000..7e99cdba96
--- /dev/null
+++ b/target/linux/generic/patches-3.0/830-ledtrig_morse.patch
@@ -0,0 +1,18 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -469,4 +469,8 @@ config LEDS_TRIGGER_DEFAULT_ON
+ comment "iptables trigger is under Netfilter config (LED target)"
+ depends on LEDS_TRIGGERS
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -54,3 +54,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
+ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
+ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o