aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.39/700-swconfig.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-16 18:31:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-16 18:31:05 +0000
commitc19a05ddc769a8b14837218fea04fe8b5c887eee (patch)
treed0285c3b8b16f40ed39ca88a77e257f6443ecb57 /target/linux/generic/patches-2.6.39/700-swconfig.patch
parent80a4ffa1e2bc5f3ef893251babb2371c502f04ad (diff)
downloadmaster-187ad058-c19a05ddc769a8b14837218fea04fe8b5c887eee.tar.gz
master-187ad058-c19a05ddc769a8b14837218fea04fe8b5c887eee.tar.bz2
master-187ad058-c19a05ddc769a8b14837218fea04fe8b5c887eee.zip
kernel: reorganize 2.6.39 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26691 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.39/700-swconfig.patch')
-rw-r--r--target/linux/generic/patches-2.6.39/700-swconfig.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.39/700-swconfig.patch b/target/linux/generic/patches-2.6.39/700-swconfig.patch
new file mode 100644
index 0000000000..6825037ce9
--- /dev/null
+++ b/target/linux/generic/patches-2.6.39/700-swconfig.patch
@@ -0,0 +1,25 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -13,6 +13,12 @@ menuconfig PHYLIB
+
+ if PHYLIB
+
++config SWCONFIG
++ tristate "Switch configuration API"
++ ---help---
++ Switch configuration API using netlink. This allows
++ you to configure the VLAN features of certain switches.
++
+ comment "MII PHY device drivers"
+
+ config MARVELL_PHY
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -3,6 +3,7 @@
+ libphy-objs := phy.o phy_device.o mdio_bus.o
+
+ obj-$(CONFIG_PHYLIB) += libphy.o
++obj-$(CONFIG_SWCONFIG) += swconfig.o
+ obj-$(CONFIG_MARVELL_PHY) += marvell.o
+ obj-$(CONFIG_DAVICOM_PHY) += davicom.o
+ obj-$(CONFIG_CICADA_PHY) += cicada.o