aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/files/fs/yaffs2/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-06-26 20:42:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-06-26 20:42:58 +0000
commita082943b09f4f707990ad0ac6326df8480507f02 (patch)
treede32e4def600e56134cd085a7447cb6620542078 /target/linux/generic/files/fs/yaffs2/Makefile
parent67fbcc7bd42cc07b1f3c6b5c9f2db37647178f25 (diff)
downloadmaster-187ad058-a082943b09f4f707990ad0ac6326df8480507f02.tar.gz
master-187ad058-a082943b09f4f707990ad0ac6326df8480507f02.tar.bz2
master-187ad058-a082943b09f4f707990ad0ac6326df8480507f02.zip
rename target/linux/generic-2.6 to generic
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21952 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/files/fs/yaffs2/Makefile')
-rw-r--r--target/linux/generic/files/fs/yaffs2/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/generic/files/fs/yaffs2/Makefile b/target/linux/generic/files/fs/yaffs2/Makefile
new file mode 100644
index 0000000000..73f46583f4
--- /dev/null
+++ b/target/linux/generic/files/fs/yaffs2/Makefile
@@ -0,0 +1,11 @@
+#
+# Makefile for the linux YAFFS filesystem routines.
+#
+
+obj-$(CONFIG_YAFFS_FS) += yaffs.o
+
+yaffs-y := yaffs_ecc.o yaffs_fs.o yaffs_guts.o yaffs_checkptrw.o
+yaffs-y += yaffs_packedtags2.o yaffs_nand.o yaffs_qsort.o
+yaffs-y += yaffs_tagscompat.o yaffs_tagsvalidity.o
+yaffs-y += yaffs_mtdif1.o yaffs_packedtags1.o
+yaffs-y += yaffs_mtdif.o yaffs_mtdif2.o