aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.32/670-phy_ip175c.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-11-03 10:49:27 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-11-03 10:49:27 +0000
commit6f4a7596370aaa61dc6f605007d72b1813e1f4f8 (patch)
tree632d6b87886f34dd23c8563f4abb2ffe58236ff5 /target/linux/generic-2.6/patches-2.6.32/670-phy_ip175c.patch
parent5b5838be6c2e2c4c637f6fa982dfd35c50904500 (diff)
downloadmaster-187ad058-6f4a7596370aaa61dc6f605007d72b1813e1f4f8.tar.gz
master-187ad058-6f4a7596370aaa61dc6f605007d72b1813e1f4f8.tar.bz2
master-187ad058-6f4a7596370aaa61dc6f605007d72b1813e1f4f8.zip
add preliminary 2.6.32 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18283 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.32/670-phy_ip175c.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.32/670-phy_ip175c.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.32/670-phy_ip175c.patch b/target/linux/generic-2.6/patches-2.6.32/670-phy_ip175c.patch
new file mode 100644
index 0000000000..862868c8d1
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.32/670-phy_ip175c.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -102,6 +102,10 @@ config ADM6996_PHY
+ config MVSWITCH_PHY
+ tristate "Driver for Marvell 88E6060 switches"
+
++config IP175C_PHY
++ tristate "Driver for IC+ IP175C/IP178C switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -16,6 +16,7 @@ obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
++obj-$(CONFIG_IP175C_PHY) += ip175c.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o