aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.32/410-gpio_buttons.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-11-03 10:49:27 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-11-03 10:49:27 +0000
commit6f4a7596370aaa61dc6f605007d72b1813e1f4f8 (patch)
tree632d6b87886f34dd23c8563f4abb2ffe58236ff5 /target/linux/generic-2.6/patches-2.6.32/410-gpio_buttons.patch
parent5b5838be6c2e2c4c637f6fa982dfd35c50904500 (diff)
downloadmaster-187ad058-6f4a7596370aaa61dc6f605007d72b1813e1f4f8.tar.gz
master-187ad058-6f4a7596370aaa61dc6f605007d72b1813e1f4f8.tar.bz2
master-187ad058-6f4a7596370aaa61dc6f605007d72b1813e1f4f8.zip
add preliminary 2.6.32 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18283 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.32/410-gpio_buttons.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.32/410-gpio_buttons.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.32/410-gpio_buttons.patch b/target/linux/generic-2.6/patches-2.6.32/410-gpio_buttons.patch
new file mode 100644
index 0000000000..95987ce48f
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.32/410-gpio_buttons.patch
@@ -0,0 +1,31 @@
+--- a/drivers/input/misc/Kconfig
++++ b/drivers/input/misc/Kconfig
+@@ -316,4 +316,20 @@ config INPUT_PCAP
+ To compile this driver as a module, choose M here: the
+ module will be called pcap_keys.
+
++config INPUT_GPIO_BUTTONS
++ tristate "Polled GPIO buttons interface"
++ depends on GENERIC_GPIO
++ select INPUT_POLLDEV
++ help
++ This driver implements support for buttons connected
++ to GPIO pins of various CPUs (and some other chips).
++
++ Say Y here if your device has buttons connected
++ directly to such GPIO pins. Your board-specific
++ setup logic must also provide a platform device,
++ with configuration data saying which GPIOs are used.
++
++ To compile this driver as a module, choose M here: the
++ module will be called gpio-buttons.
++
+ endif
+--- a/drivers/input/misc/Makefile
++++ b/drivers/input/misc/Makefile
+@@ -30,4 +30,5 @@ obj-$(CONFIG_INPUT_WINBOND_CIR) += winb
+ obj-$(CONFIG_INPUT_WISTRON_BTNS) += wistron_btns.o
+ obj-$(CONFIG_INPUT_WM831X_ON) += wm831x-on.o
+ obj-$(CONFIG_INPUT_YEALINK) += yealink.o
++obj-$(CONFIG_INPUT_GPIO_BUTTONS) += gpio_buttons.o
+