aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.31/050-lzo_compressed_kernels.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-11-30 10:32:20 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-11-30 10:32:20 +0000
commitf727f720444ca42f786751012476b3ebf495ba6a (patch)
tree77199bd018c3ed0dfd1fbe69ca0df8e0dc1027ff /target/linux/generic-2.6/patches-2.6.31/050-lzo_compressed_kernels.patch
parente99873dd96c9412f02765ae1bb3c30edb4fa8d37 (diff)
downloadmaster-187ad058-f727f720444ca42f786751012476b3ebf495ba6a.tar.gz
master-187ad058-f727f720444ca42f786751012476b3ebf495ba6a.tar.bz2
master-187ad058-f727f720444ca42f786751012476b3ebf495ba6a.zip
upgrade x86 to 2.6.31.6, resync patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18609 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.31/050-lzo_compressed_kernels.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/050-lzo_compressed_kernels.patch12
1 files changed, 0 insertions, 12 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.31/050-lzo_compressed_kernels.patch b/target/linux/generic-2.6/patches-2.6.31/050-lzo_compressed_kernels.patch
index fad1b87466..733d1756f6 100644
--- a/target/linux/generic-2.6/patches-2.6.31/050-lzo_compressed_kernels.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/050-lzo_compressed_kernels.patch
@@ -1,6 +1,3 @@
-diff --git a/include/linux/decompress/unlzo.h b/include/linux/decompress/unlzo.h
-new file mode 100644
-index 0000000..9872297
--- /dev/null
+++ b/include/linux/decompress/unlzo.h
@@ -0,0 +1,10 @@
@@ -14,8 +11,6 @@ index 0000000..9872297
+ int *pos,
+ void(*error)(char *x));
+#endif
-diff --git a/init/Kconfig b/init/Kconfig
-index f515864..eb65318 100644
--- a/init/Kconfig
+++ b/init/Kconfig
@@ -115,10 +115,13 @@ config HAVE_KERNEL_BZIP2
@@ -60,9 +55,6 @@ index f515864..eb65318 100644
endchoice
config SWAP
-diff --git a/lib/decompress_unlzo.c b/lib/decompress_unlzo.c
-new file mode 100644
-index 0000000..2bb736f
--- /dev/null
+++ b/lib/decompress_unlzo.c
@@ -0,0 +1,208 @@
@@ -274,8 +266,6 @@ index 0000000..2bb736f
+}
+
+#define decompress unlzo
-diff --git a/lib/lzo/lzo1x_decompress.c b/lib/lzo/lzo1x_decompress.c
-index 5dc6b29..f2fd098 100644
--- a/lib/lzo/lzo1x_decompress.c
+++ b/lib/lzo/lzo1x_decompress.c
@@ -11,11 +11,13 @@
@@ -306,8 +296,6 @@ index 5dc6b29..f2fd098 100644
MODULE_DESCRIPTION("LZO1X Decompressor");
+#endif
-diff --git a/scripts/Makefile.lib b/scripts/Makefile.lib
-index ffdafb2..39c3483 100644
--- a/scripts/Makefile.lib
+++ b/scripts/Makefile.lib
@@ -230,3 +230,8 @@ quiet_cmd_lzma = LZMA $@